0

My Samsung s7 (SM-G930F) works for making calls on 'normal' (non speaker phone) mode in all apps. but whenever i switch to speaker phone (regardless of the app i am using) the other side (the person I'm calling) can't hear me anymore. As soon as I switch to non-speaker-phone mode the other side can hear me again. It also doesn't work in video calls (the other side can't hear me when video calling).

Note: voice recorder also works just fine.. Note2: with headphones installed (via headphone jack) it also works (other side can hear me just fine)

I've tried the following:

  • reset to factory settings
  • clean microphone/speaker port+holes
  • checked microphone connector (if it was properly installed, it is)
  • cleared cache partition in android recovery menu (no change)
  • tried it in safe mode (problem persists)
  • and countless other 'fixes' which unfortunately did not work for me...

I have a custom ROM installed (I tried to find something as close to the stock ROM as possible). I previously had Lineage OS 16.0 Herolte installed but on that ROM Roaming did not work so that's why I decided to install a different ROM. Currently installed ROM I am not 100% sure of, will check tonight. I believe I followed this video tutorial so I should have the android 8.0 ROM installed from sammobile.com: https://www.youtube.com/watch?v=LvPL6hskf6w. On the current ROM Roaming does work.

I believe the current ROM causes the issue since speaker phone was working on lineage OS previously.

Are there any other fixes/tests I could try to determine/fix the issue?

Any recommendations on where to find/download stock Android 8.0 ROM for the SM-G930F?

Thank you!

1

Dunno about the fixes, but since you also asked for a ROM, here it is

| improve this answer | |
  • thank you! I will try that ROM , hope it fixes the issue :) – Maarten -Monica for president Apr 14 at 12:19
  • I have installed the Rom you suggested but unfortunately the issue with the speaker phone did not go away :/ thank you for the suggestions nonetheless – Maarten -Monica for president Apr 20 at 17:30
  • How did you put it on the device? Through TWRP or just how you are supposed to do it, through fastboot? – Tiebe Groosman Apr 21 at 10:47
  • @ Tiebe Groosman I did not use TWRP . I used odin v3.14.4 ... put the phone in download mode, selected the files in odin, pressed start. Odin gave no errors. after that the phone screen said "erasing" and after that "applying update" after which the inital setup screen of android (select language, country etc.) appeared. In oding I selected the CSC file which erases everything/does a clean install (so not the "CSC_HOME" version of the file). I followed this tutorial: youtube.com/watch?v=7SK3IMprKVQ Should I be using TWRP? – Maarten -Monica for president Apr 21 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.