1

I have a Samsung J7 Prime model SM-G610M, earlier today I got TWRP working perfectly after many other issues, however, when I tried to flash SuperSU from the sd card, it got stuck in a bootloop, the device vibrates, the screen lights up and shows the device name and blacks out again. And I think it's important to say that I simply couldn't access TWRP after endless methods, so far I've tried, among others:

  1. Entering recovery mode from the button combination home+power+volume, no success as my home button is broken.

  2. Entering fastboot mode from power+volume down or power+volume up or just volume down+volume up, but everywhere it says the device needs to be turned off first, and I can't do this, trying to turn it off just returns the loop.

  3. Running adb/fastboot from the console with commands such as fastboot oem unlock with and without sudo privileges. Until now I've used adb just fine after allowing it on the device OS while fastboot just never worked, I think my device model isn't supported but I could be wrong of course. Adb simply doesn't recognize the device as I can't allow on it directly.

    3.1 It seems that the device isn't being recognized by the computer as it doesn't show in lsusb, I've previously tried other cables and USB ports, and the current combination works just fine in normal situations.

  4. Running Odin or Heimdall, doesn't recognize the device as it isn't in bootloader mode.

    4.1 Previously I had some issues with Odin, when in bootloader mode and Odin asked for a .pit file, the device rebooted to the normal OS, rendering the program useless, I ended up using Heimdall to flash TWRP.

  5. Using the SP Flash Tool, this was my latest attempt, but I couldn't even get it running because I'm lacking the scatter file, every article mentions using MTK droid tools to retrieve it, but I couldn't find a version that wasn't for windows, and I'm running Ubuntu 18.04.

  6. The only thing that I've read and didn't try was using the button combination after the battery was drained because it isn't yet (it had around 70%).

I didn't think the device could be bricked (maybe soft-bricked at most) but after almost 6 hours of this stressful situation I barely have any hope left. If anyone could help me with this I would be so grateful.

Edit: Just tried from the device with the battery drained, it's the same.

  • forum.xda-developers.com/showthread.php?t=3829731 SuperSU is outdated. MTK droid tools is outdated. SP Flash Tool is for Mediatek Chipset only. Samsung devices don't have fastboot. try JIG Dongle to get Heimdall working, or search for unbrick guide with Qualcomm HS-USB QDLoader 9008 Driver in EDL mode – alecxs Apr 16 at 10:05
  • 1
    I looked at the link you provided but couldn't find anything that applied to my situation as everything depended on the USB connection, in fact, I had seen this page on my searches before. I'll try to get my hands on a JIG Dongle as you said, because I don't have one and can't seem to be able to make one from a USB drive and a OTG cable. Thanks for your response. – lima1889 Apr 16 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.