I am using Asus Zenfone 3 ZE552KL, it got hang and then i tried to restart the phone but it get stucked in, Also I can't get in to recovery using standard method. Generally I keep USB debugging mode off that's why my device not listed in adb devices list but, i can go into CSC Fastboot mode. fastbootmod

Text in the image. csc fastboot mode!!! long time press power button to restart I tried below solutions

  1. Used Asus Flash tool as per its help doc the process takes 10 to 15min but i wait around more than 2 hours it shows "Uploading OS Version"
  2. I downloaded Firmware zip file from asus official site, but in zip file only boot.img is present other two requried files are missing recovery.img and fastboot.img

Firware Folder

Kindly suggest me some workaround.

  • Hi @alecxs, Thanks for your answer. Just want to know from where I can get twrp-3.2.3-zenfone3-20180806.img file Commented Apr 20, 2020 at 11:09
  • got it, tried your method and getting this error Sending 'boot.img' (21090 KB) FAILED (Write to device failed (Unknown error))" Commented Apr 20, 2020 at 14:45
  • please try flashall_AFT.cmd it may work with locked bootloader (link see answer below)
    – alecxs
    Commented Apr 21, 2020 at 20:24
  • @alecxs i tried flashall_AFT.cmd method, and got this error "FAILED (remote: failed to write partition)". I think need to set some permissions to write data, is it so? Commented May 17, 2020 at 11:28
  • then you are left with EDL mode
    – alecxs
    Commented May 17, 2020 at 13:59

1 Answer 1


The Asus Zenfone Flash Tool is no official Software, furthermore it looks like this tool is using fastboot (which usually works on previously unlocked bootloader only)

for fastboot.exe download platform-tools and open cmd.exe. navigate to platform-tools folder with cd now you can type

fastboot reboot

if bootloader is already unlocked, you can also wipe cache partition and see if this fixes your boot problem

fastboot format:ext4 cache

you can also boot into recovery from fastboot and then install firmware update.zip. this should even work from TWRP as long as you don't flash recovery.
do NOT allow modifications of system. just wipe cache partition. try to reboot into system from menu. if still not booting, install firmware update.zip

fastboot boot C:\platform-tools\twrp-3.2.3-zenfone3-20180806.img

for locked bootloader you can download Factory_Phone-userdebug.raw emmc image which contains GPT partition table and all partitions. (from linux it is possible to loop-mount this image with kpartx and split into partitions, but this is out of scope)

WARNING: all data lost
this will flash the entire device, be aware this deletes all your personal data. make sure this is the right phone model.
download CSC_ZE552KL_13_13_1_36_M2_6_7_P7_userdebug.zip.
it seems no flash tool is needed, it is maybe working from fastboot directly.
connect usb cable in fastboot mode and just run flashall_AFT.cmd

Qualcomm Devices usually can be flashed from EDL mode with QPST.
found a site with some Qualcomm EDL Programmers maybe one of this works for your device

for EDL mode install Qualcomm HS-USB QDLoader 9008 Driver

for EDL mode you need to find Test Point



The following is just an example to illustrate the process and not valid instructions

For further documentation refer to alephsecurity there you can learn how to flash devinfo which unlocks bootloader and gives availbilitiy to flash custom recovery TWRP

basically you need the following files (most of them are included in QPST)


the xml file has instructions for flashing partition, for example TWRP (not the right size/offset)

<?xml version="1.0" ?>
 <program SECTOR_SIZE_IN_BYTES="512" file_sector_offset="0" filename="recovery.img" label="recovery" num_partition_sectors="131072" physical_partition_number="0" size_in_KB="65536.0" sparse="false" start_byte_hex="0x1c200000" start_sector="921600" />

QSaharaServer.exe is used to initialize firehose with on the already to COM port connected device in EDL mode

QSaharaServer.exe -p \\.\COM10 -s 13:prog_emmc_firehose_8953.mbn -b tmp\"

fh_loader.exe is responsible for flashing the instructions from xml file

fh_loader.exe --search_path=tmp --port=\\.\COM10 --sendxml=twrp.xml"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .