I recently rooted and upgraded my Samsung Galaxy S2 to version 4, ICS.

Since doing so, when I connect my device by USB to my Ubuntu computer, only the 12GB internal storage shows up on my desktop and in Banshee.

How do I get my 16GB SD card to also mount on Ubuntu, so that it is available for transferring music files and so on?


According to one answer below, and also in instructions I've now seen elsewhere on the web, I should be able to adjust my USB connection mode by following the following instructions:

1.Bring up Settings.

2.Click More… (under Wireless and network).

3.Then select USB utilities ~ Set USB cable connection mode.

4.Select Connect storage to PC

However, I am stopped at step 3 because I do not have a "USB Utilities" option under Settings -> More.... What I have looks like this:

settings more

I don't know if this is the make-or-break factor that will get my USB connectivity as hoped, but in any case, shouldn't I have the option since everyone else seems to? What can I do to get it?


Here is the storage settings as seen on my phone. As you can see, there are 2 entries of "Internal Storage", one of about 2GB, and one of a little under 12GB.

Then there is an "SD Card", which seems to have about 15 GB, but it is grey and I am unsure if this is really my SD card or not.

Then under "USB Storage", I have the option to mount an SD card, which is problematic, because I already have my card inserted, and seemingly mounted (as described after this image):

storage settings

If I press the menu key while in the storage settings interface, I get two options:


For "USB computer connection", I have these settings which I don't think I want to change, because MTP does not work with my Galaxy Tab, so I'm not confident it will work with my Galaxy S2. I tried the camera option, but that made it so my phone appeared with a camera icon on my computer, limited the directories, and did not do much to help:

USB computer connection

For "Storage configuration", I tried "Use internal Storage" both on and off, but it does not seem to make a difference:

storage configuration

Here is a screen shot from PowerAmp, which seems to think my music is located in a directory called "emmc". The music is accessible from within PowerAmp, but I can not access it when I connect my phone by USB:

power amp emmc

PowerAmp tells me I can actually find the emmc directory, where my music seems to be stored, in two locations, /emmc and /mnt/emmc:

power ampt two emmcs

When I connect my phone by USB, it looks like this. Note no emmc directory, nor any Music directory, and if you look at the side, there is one 12 GB Filesystem, no entry for my 16GB SD card:

12GB filesystem

And lastly here is the 12 GB drive's properties:

12GB properties

  • In the Samsung stock ROM the external SD card is under /sdcard or /usb_storage Apr 28, 2012 at 7:17
  • @UriHerrera: Thanks for responding. It doesn't seem to be the case with my phone in its current state. There is an /sdcard directory, but when mounted by USB, if I transfer files there, they are then on the internal storage, not the external SD card. Also, the drive only shows 12GB available, whereas I should have 12GB + an additional 16GB for the SD card. Lastly, Banshee does not automatically recognize the 16GB space where my music files like it did before, which is problematic. The last thing I want to do is start fighting with Banshee settings to get it to see a subdirectory.
    – Questioner
    Apr 28, 2012 at 8:01
  • Try it over Wi-Fi: android.stackexchange.com/a/20693/3303
    – iOS
    Apr 28, 2012 at 9:14
  • Did something you do partition the SD card?
    – Logos
    May 18, 2012 at 10:18
  • @Logos: Not that I know of. I certainly didn't intend to.
    – Questioner
    May 18, 2012 at 15:03

7 Answers 7

  1. There's no problem with Ubuntu, problem is most probably in your phone settings or your phone system. It would be very helpful to know from which source did you get your upgrade, was it official update from your phone provider or something found on the net?

  2. According to your picture you have 12GB of internal storage and 16GB SD card inserted in your phone. Numbers you see are the result of conversion of bytes (which is 16GB as memory or HDD manufacturers think) into the gigabytes, each containing 1024*1024*1024 = 1073741824 bytes. If you divide the by 1024*1024*1024 you'll get your 14.9GB or something.

  3. Grayed out "Mount SD card" under USB storage possibly represents the external USB storage you might insert into the USB port of your phone. There's no reason to click on it, unless you have the external USB storage plugged in. And even then, I'm not sure if this is actually supported on SGS2.

  4. Missing from your screen grabs, there supposed to be a "menu" option below the "Storage" page, usually represented as three dots aligned one above the other. If you click on this "menu", you'll most probably be shown "USB computer connection" submenu or something similar. Once you get there, you may change how your phone represents the memory you have to the computer. If you make a screen grab of that screen, I could tell you which option to select.

  5. As a side note, it's not a very good idea to remove/insert SD card without unmounting it first. Please, next time you remove SD card from your phone, power the phone off or issue "Unmount SD card" from the "Storage" screen you've shown in the question.

If you could not find "USB computer connection" submenu on the Storage screen, you may try this approach to make USB mass storage to work on your device:

  1. Open Settings, then click More… (under Wireless and network).
  2. Select USB utilities / Set USB cable connection mode.
  3. Select "Connect storage to PC".
  4. Connect USB cable from phone to PC.
  5. Click "Turn on USB storage".

Also, you might need to turn OFF "USB debug" before trying this.

  • Thank you for responding. I had not noticed the storage options before. On my phone, the menu option is accessed by a button, so it does not appear in the screen shots. In any case, I have found it and tried the options presented. Please see my updated question for details. I have also cleaned up and fleshed out my question with more accurate details. Lastly, I have never removed the SD card without first unmounting and turning off the phone, so I don't think that is a source of the problem. :)
    – Questioner
    May 21, 2012 at 9:43
  • Thank you, that's great. Have you tried "Settings -> More... -> USB utilities" as described in the second part of my answer?
    – lenik
    May 21, 2012 at 11:08
  • 1
    If I go to System Settings -> Wireless & networks -> More..., I do not see a "USB Utilities" option. I have "Airplane Mode", "VPN", "Tethering & Portable hotspot", "Wi-Fi direct", and "Mobile networks". The ROM I used to upgrade is the "Android Open KANG Project". As far as I understand it is a fairly reliable ROM, but I have to admit I do not know enough about ROMs to make definitive judgments. It came recommended, that's all I know.
    – Questioner
    May 21, 2012 at 12:39
  • The answer was simply to reflash the ROM which I put in my own answer, but I awarded you the bounty for having the most complete attempt at a resolution. :)
    – Questioner
    May 24, 2012 at 12:18

You can also try mounting the SD card from recovery mode. select mount usb storage.


I've tried connecting the Galaxy Note with a SD to my Ubuntu installation (11.04) and it recognizes both.

Make sure you have USB Debugging enabled.


I don't know why upgrading to ICS would make a difference to mounting your ext SD card if you could connect before, but you might want to doublecheck that your Ubuntu system's udev config is correct:

  • doublecheck that the vendor ID for your Galaxy is 04e8 using sudo lsusb; you should see a line something like Bus 002 Device 010: ID 04e8:0c02 Samsung Corp
  • using your favourite editor as root edit (or create) "/etc/udev/rules.d/51-android.rules” and add this line: SUBSYSTEM=="usb", SYSFS{idVendor}=="04e8", MODE="0666"
  • make sure the perms are right for the file you just edited: sudo chmod a+rx /etc/udev/rules.d/51-android.rules
  • restart the USB subsystem: sudo restart udev
  • connect your Galaxy and see if your SD card shows up now
  • Thank you for responding. Running lsusb gets me this response: Bus 002 Device 011: ID 04e8:685b Samsung Electronics Co., Ltd GT-I9100 Phone [Galaxy S II] (mass storage mode). However, after following your instructions to the letter, I still only see the 12GB internal storage.
    – Questioner
    May 18, 2012 at 2:44
  • Also, I should note that I just tested on my laptop, and I get the same problem of not seeing my internal SD card, so it seems less likely to me that the problem is on the Ubuntu side. It's not absolute proof, but it does seem unlikely that both computers would have the same settings issues.
    – Questioner
    May 18, 2012 at 4:57
  • Agreed. Too bad, was worth a shot :( Have you tried plugging the SD into a card reader and seeing if the card shows up that way? The file system may be damaged and need fixing (though that's unlikely if it shows up OK under the Android system). Failing that, I'd say it's time to talk to whoever you bought it from about a possible hardware issue.
    – Logos
    May 18, 2012 at 10:15

The solution was to wipe and reflash the ROM. I guess the earlier ROM I had was just messed up as far as USB is concerned.


On my Samsung Galaxy S II model GT-I9100, I have to do the following to enable mounting on Linux:

  1. Go to Settings → Storage
  2. Click the menu button
  3. Go to "USB computer connection"
  4. Click anything other than "Mass storage"
  5. Click "Mass storage"

This brings up the old familiar "USB mass storage" screen with a big friendly "Turn on USB storage" button.

On Arch I also had to install the fuse-exfat package.


Easiest way I know, a little late, but if you are stilll wondering. When you plug in your phone to the computer, it comes up under drive H, I believe, and then a secondary drive opens. Also on my windows computer it's under drive J, and that there is your SD card.

  • I'm still wondering how does this answer relates to the question. Drive letters are specific to MS-DOS based OS (aka Windows). Ubuntu (Linux) doesn't uses them.
    – Firelord
    May 1, 2015 at 12:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .