1

My speakerphone isn't working correctly.. Whenever I switch to speaker phone in a call /video call the other person cannot hear me. The other person can hear me only when I am calling via either headphones or non-speakerphone mode.I recently installed/flashed the stock firmware (android 8.0) onto my samsung galaxy SM-G930F to try and fix the issue (to no avail unfortunately).

I previously had Lineage OS 16.0 Herolte (on which speaker phone worked perfectly) installed but on that ROM Roaming did not work so that's why I decided to install a different ROM. Currently installed ROM is android 8.0 stock firmware downloaded from this link: https://www.sammobile.com/samsung/galaxy-s7/firmware/SM-G930F/PHN/download/G930FXXS8ETC3/327932/ I thought installing original firmware would fix the issue but unfortunately not.. Am I doing something wrong?

Notes:

  • The microphone is working perfectly (when tested using voice recorder)
  • the issue is definitely with the samsung s7 phone not with the phone of the person of the other side of the line (this issue occurs regardless of who is being called from the s7)
  • I have tested it with many apps (phone app, whatsapp, discord, skype, hangouts), all give the same issue

I have tried:

  • rebooted many times
  • I cleaned the speaker ports and microphone port (all are clean now)
  • flash original firmware (android 8.0)(currently installed OS)
  • starting phone in safe mode
  • wiping system cache
  • plugging in/out a headphone into the headphone jack many times
  • unplugging headphone connector on Motherboard (made no difference)
  • I checked the contacts on the speaker assembly (which connect to the MB), they look clean and in pristine condition

To summarize: When I am in a call (regardless of what app I am using) it works fine as long as my phone (s7) is not in speaker-phone mode (in this case the other person can hear me and all works as it should), as soon as I switch to speaker phone mode I can still hear the other person but the other person cannot hear me anymore.

I downloaded the firmware from Sammobile.com as suggested by quite a few tutorial videos. I downloaded the version for the correct country (the Netherlands), for correct phone model (SM-G930F); here is a link to the page I downloaded the firmware from: https://www.sammobile.com/samsung/galaxy-s7/firmware/SM-G930F/PHN/download/G930FXXS8ETC3/327932/

I flashed using ODIN V3.14.4 as suggested on the download page, all appeared to have gone well, ODIN gave no errors and said "passed" when it was done flashing..

I downloaded the version "Netherlands (PHN)"

I have tried all the 'fixes' I could find so far on the internet but nothing has worked yet, i need some help. Any suggestions on what I could try/test to make it work again would be very much appreciated! Thank you so much!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.