2

My Xiaomi Redmi Note 6 Pro broke and 3/4 screen is completely black, I can't see anything but a little part below

enter image description here

Other than that, the touch doesn't work AND sometimes the screen triggers some random coordinate touch. If that's not enough, Xiaomi devices must be unlocked at least 1 time after startup with pattern, but can't. I usually use biometric unlock such as fingerprint sensor and facial recognition but, again, can't.

I want to still use it anyways as a mobile hotspot. I managed to turn on mobile data on adb but, trying to activate hotspot like suggested in this post, so adb shell service call connectivity 24 i32 0, I receive this output:

Result: Parcel(
0x00000000: fffffffc 00000019 00610063 006c006c '........c.a.l.l.'
0x00000010: 006e0069 00500067 0067006b 00630020 'i.n.g.P.k.g. .c.'
0x00000020: 006e0061 006f006e 00200074 00650062 'a.n.n.o.t. .b.e.'
0x00000030: 006e0020 006c0075 0000006c 00000330 ' .n.u.l.l...0...'
0x00000040: 00000193 00610009 00200074 006f0063 '......a.t. .c.o.'
0x00000050: 002e006d 006e0061 00720064 0069006f 'm...a.n.d.r.o.i.'
0x00000060: 002e0064 006e0069 00650074 006e0072 'd...i.n.t.e.r.n.'
0x00000070: 006c0061 0075002e 00690074 002e006c 'a.l...u.t.i.l...'
0x00000080: 00720050 00630065 006e006f 00690064 'P.r.e.c.o.n.d.i.'
0x00000090: 00690074 006e006f 002e0073 00680063 't.i.o.n.s...c.h.'
0x000000a0: 00630065 004e006b 0074006f 0075004e 'e.c.k.N.o.t.N.u.'
0x000000b0: 006c006c 00500028 00650072 006f0063 'l.l.(.P.r.e.c.o.'
0x000000c0: 0064006e 00740069 006f0069 0073006e 'n.d.i.t.i.o.n.s.'
0x000000d0: 006a002e 00760061 003a0061 00320031 '..j.a.v.a.:.1.2.'
0x000000e0: 00290038 0009000a 00740061 00610020 '8.).....a.t. .a.'
0x000000f0: 0064006e 006f0072 00640069 006e002e 'n.d.r.o.i.d...n.'
0x00000100: 00740065 0043002e 006e006f 0065006e 'e.t...C.o.n.n.e.'
0x00000110: 00740063 00760069 00740069 004d0079 'c.t.i.v.i.t.y.M.'
0x00000120: 006e0061 00670061 00720065 0065002e 'a.n.a.g.e.r...e.'
0x00000130: 0066006e 0072006f 00650063 00650054 'n.f.o.r.c.e.T.e.'
0x00000140: 00680074 00720065 00680043 006e0061 't.h.e.r.C.h.a.n.'
0x00000150: 00650067 00650050 006d0072 00730069 'g.e.P.e.r.m.i.s.'
0x00000160: 00690073 006e006f 00430028 006e006f 's.i.o.n.(.C.o.n.'
0x00000170: 0065006e 00740063 00760069 00740069 'n.e.c.t.i.v.i.t.'
0x00000180: 004d0079 006e0061 00670061 00720065 'y.M.a.n.a.g.e.r.'
0x00000190: 006a002e 00760061 003a0061 00300032 '..j.a.v.a.:.2.0.'
0x000001a0: 00330035 000a0029 00610009 00200074 '5.3.).....a.t. .'
0x000001b0: 006f0063 002e006d 006e0061 00720064 'c.o.m...a.n.d.r.'
0x000001c0: 0069006f 002e0064 00650073 00760072 'o.i.d...s.e.r.v.'
0x000001d0: 00720065 0043002e 006e006f 0065006e 'e.r...C.o.n.n.e.'
0x000001e0: 00740063 00760069 00740069 00530079 'c.t.i.v.i.t.y.S.'
0x000001f0: 00720065 00690076 00650063 0073002e 'e.r.v.i.c.e...s.'
0x00000200: 00610074 00740072 00650054 00680074 't.a.r.t.T.e.t.h.'
0x00000210: 00720065 006e0069 00280067 006f0043 'e.r.i.n.g.(.C.o.'
0x00000220: 006e006e 00630065 00690074 00690076 'n.n.e.c.t.i.v.i.'
0x00000230: 00790074 00650053 00760072 00630069 't.y.S.e.r.v.i.c.'
0x00000240: 002e0065 0061006a 00610076 0033003a 'e...j.a.v.a.:.3.'
0x00000250: 00300033 00290038 0009000a 00740061 '3.0.8.).....a.t.'
0x00000260: 00610020 0064006e 006f0072 00640069 ' .a.n.d.r.o.i.d.'
0x00000270: 006e002e 00740065 0049002e 006f0043 '..n.e.t...I.C.o.'
0x00000280: 006e006e 00630065 00690074 00690076 'n.n.e.c.t.i.v.i.'
0x00000290: 00790074 0061004d 0061006e 00650067 't.y.M.a.n.a.g.e.'
0x000002a0: 00240072 00740053 00620075 006f002e 'r.$.S.t.u.b...o.'
0x000002b0: 0054006e 00610072 0073006e 00630061 'n.T.r.a.n.s.a.c.'
0x000002c0: 00280074 00430049 006e006f 0065006e 't.(.I.C.o.n.n.e.'
0x000002d0: 00740063 00760069 00740069 004d0079 'c.t.i.v.i.t.y.M.'
0x000002e0: 006e0061 00670061 00720065 006a002e 'a.n.a.g.e.r...j.'
0x000002f0: 00760061 003a0061 00380033 00290031 'a.v.a.:.3.8.1.).'
0x00000300: 0009000a 00740061 00610020 0064006e '....a.t. .a.n.d.'
0x00000310: 006f0072 00640069 006f002e 002e0073 'r.o.i.d...o.s...'
0x00000320: 00690042 0064006e 00720065 0065002e 'B.i.n.d.e.r...e.'
0x00000330: 00650078 00540063 00610072 0073006e 'x.e.c.T.r.a.n.s.'
0x00000340: 00630061 00280074 00690042 0064006e 'a.c.t.(.B.i.n.d.'
0x00000350: 00720065 006a002e 00760061 003a0061 'e.r...j.a.v.a.:.'
0x00000360: 00330037 00290035 0000000a          '7.3.5.).....    ')

I also wanted to install an application on the phone to control it through the pc, but can't because it needs confirmation from phone itself.

After I tried to use a screen unlocker bash file (through windows ubuntu subsystem) and, finding the coordinates for the points, the screenshots from the phone lock screen are blank so I can't see which coordinates they are.

After that I also tried to use AdbControl (written in Java), which should stream the phone to the pc , but it gives me errors for every single frame.

I tried also Mi Suite with no luck: although I connected my device it shows this:

enter image description here

Any thoughts?

1

for adbcontrol you must escape backslash in windows path and specify a writeable path on device for example /storage/emulated/0 which probably fails because location isn't available during unlock/decryption. depending on permissions you can maybe use external MicroSD card instead

adbCommand = C:\\platform-tools\\adb.exe
screenshotDelay = 100
localImageFilePath = C:\\adbcontrol\\adbcontrol_screenshot.png
phoneImageFilePath = /storage/4D47-9860/adbcontrol_screenshot.png

you can also use scrcpy instead


another manual method for unlock/decryption (only works for password)

adb shell input keyevent KEYCODE_SPACE
adb shell input text <password>
adb shell input keyevent KEYCODE_ENTER

another option is physical keyboard connected via usb-otg adapter

| improve this answer | |
  • btw you are lucky that you previously enabled usb-debugging :) – alecxs Apr 21 at 14:46
  • Yes, I made some apps and needed to do it ;) btw I haven't got an OTG, I'm gonna try the first two methods – Simone Broili Apr 21 at 16:03
  • I am getting this error and this is config. I watched the source code and there shouldn't be errors... – Simone Broili Apr 21 at 18:47
  • changed to /storage/emulated/0/DCIM/ADBC/adbcontrol_screenshot.png. This doesn't resolve anything: exact same error – Simone Broili Apr 21 at 22:49
  • Thank you so much, with scrcpy works the first time! The last thing I ask you is: how can I disable touch since the phone, with the broken screen, keeps interfering with the touch? – Simone Broili Apr 22 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.