0

I'm trying to install Android-x86 on USB for my new HP laptop. I have followed the instructions on Android-x86.org. My issue is that after the initial install, it never boots again, it just gets stuck on the Android logo.

I have seen a few posts such as this answer:

when you change the internal frame where the UEFI firmware settings to the EFI framework setting change the boot order you have to make a small partition for grub go back and change it back otherwise it won't boot the second time

but unsure of how to do this.

I have also seen this answer:

  1. In boot menu select Installation - Install Android-x86 to harddisk
  2. In Choose Partition menu select Create/Modify partitions
  3. In Do you want to use GPT question select No
  4. cfdisk program will open
  5. Select New and select Primary as partition type, set size to 100 MB and select Beginning
  6. Select bootable. Now the Flags column should say Boot for the new partition
  7. Select the free space and select New and select Primary as partition type, leave size as default to fill the remaining free space
  8. Select Write and type yes and press Enter
  9. Select Quit

but I'm stuck in the fact when I click on create/modify on this, I get cgdisk not cfdisk, and it's not as easy to use. I don't know why this is happening. Before I realised what to do, I was accessing cfdisk, but now it's only cgdisk.

I have purchased 4 premium USB sticks just in case the issue was due to a bad USB, but it's not the case and I'm just so frustrated.

Any help at all would really be appreciated.

1

well I've found something that might help you ... I recently installed androidx86-9.0-rc1 as a dual boot (unlike you) , and I too faced this same problem that it booted for the first time just fine but gets stuck in subsequent boots ...

so I tried uninstalling, re-installing it to see what's wrong and what I found that when I am on Windows and from there I try to switch to already-installed androidx86 [by choosing restart option in windows / by entering bios from windows and then booting to androidx86] , it gets stuck [and gets stuck in subsequent times too, once you did such] ...

so for this , you must boot to androidx86 directly after you Power on your pc when it's initially shutted down

supposedly you're on windows , and say you want to switch to androidx86 [newly re-installed , not the one that got stuck ] , so dont restart windows ; just shut down the pc and power it on to boot to androidx86 ... just note that this is my observation only for dual-boot case

0

Sometimes, it takes a long time until you boot through the Android logo screen

You can try adding

nomodeset xforcevesa

to the boot options according to this video.

The video is created by me as a part of our free video tutorials service on demand. That means anyone can ask us for instruction in a video and we will create the tutorial for free.

The instructions are as follows:

  1. After starting Android, select the first boot option and don't press enter.
  2. Select E.
  3. Select E again.
  4. Now move the cursor left, by pressing the left key until you reach the word quiet.
  5. Replace quiet with nomodeset xforcevesa.
  6. Press Enter.
  7. Press B to boot this option.
  8. Wait until Android loads, which may take a long time in some cases.

Please use the Auto installation option, if this is the only OS on your laptop. Auto installation tutorial.

Instructions: Auto installation option enter image description here

5
  • Thanks for getting back to me, i have tried auto installation before, straight to the usb but same thing happens, my laptop is remaining on windows, im just trying to make an android usb, and then can switch to which ever os i want.. in relation to above, how exactly to i add "nomodeset xfrocevesa" and where does it go.. thanks Apr 21 '20 at 21:26
  • Please provide a video or screenshots to exactly what you are doing. Its becomes harder to debug an issue remotely if we don't know the details. Apr 21 '20 at 23:17
  • ok so im really having issues, i have even tried a different rom, ie bliss os, but still same issues, i install the image to usb, i have used rufus, as well as various others incase that didnt work, i then boot to uefi, and click to install to a 2nd usb.. i have tried to modify the usb stick 1st with cfdisk but for some reason this takes me to cgdisk which is not the same Apr 22 '20 at 8:36
  • how can i add photots or videos on this site to show what i have done, i do not see the icon to add them Apr 22 '20 at 8:46
  • You can upload a video or pictures at your favourite host(like Dropbox.com) and post the link here as a comment. Apr 22 '20 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.