0

Very annoying.

I'm trying to install LineageOS on Samsung Galaxy S5 Plus (SM-G901F), which used to run with stock OS before.

  • I successfully installed TWRP
  • I backed up my partitions and wiped them
  • Downloaded Lineageos (lineage-16.0-20200416-nightly-kccat6-signed)
  • Downloaded Addonsu (addonsu-16.0-arm-signed)
  • Downloaded OpenGApps
  • Installation of all packages in one run seems to finish without problems.
  • When I start the system it takes half an hour to boot but eventually resets and boots into recovery. I never get to see more than the moving bubbles.

I tried the following OpenGApps-packages:

  • open_gapps-arm-9.0-aroma-20200418 (wouldn't even install)
  • open_gapps-arm-9.0-super-20200418
  • open_gapps-arm-9.0-stock-20200418

outcome is the same for all. I also tried without addonsu, but outcome was the same. Now, what are the next steps? Or what did I miss?

  • Is the storage of my phone too small?
  • Did I select wrong OS version?
  • does the opengapps version not match that of the OS?
  • Should I try without opengapps?

Update

Using nightly build 20200423 with opengapps-nano worked. But not with addonsu. Can I install addonsu later? Or does it suffer the same problem as opengapps that it can't be installed in a second run?

  • 2
    Just to make sure, are you following the official guide and tried 'nano' for OpenGApps instead? – Andrew T. Apr 22 at 10:08
  • Yes, followed official guide, tried also nano now. Same result. – Ariser - reinstate Monica Apr 23 at 5:11
  • 1
    If something does not work fall back to the bare minimum (LineageOS without su and GApps). You are using a nightly version - those versions can work but does not have to. Try a newer or older version (several days). Make sure you also wipe the data partition. – Robert Apr 24 at 18:05
  • Ha! Installing the latest lineageos-version w/o additional stuff worked. I'm going to inch forward. Thanks so far, I'm doing more tests and update either my question or report success. – Ariser - reinstate Monica Apr 24 at 19:42
  • Update: Installing with lineageos and opengapps w/o addonsu worked. I'll add that to the question. – Ariser - reinstate Monica Apr 25 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.