It's an Android 4.0.3. I'm trying to fix my tablet, because it doesn't start anymore.

running fastboot devices returns nothing.

Then, I'm trying to do that through adb. adb devices returns

List of devices attached
20080411        device

So I guess adb should be working, but when I try this I get a segmentation fault:

adb shell 

I already tried many varations of button pressing on powerup, but nothing seems to work.

Any idea on how to fix it?

  • 1
    The linky has expired, getting redirected back to paste.ideaslabs.com instead ...
    – t0mm13b
    Jun 27, 2012 at 20:37
  • Member is inactive since May,9th. Just edit the question and remove the ', the strace log ...' part of the line maybe. He'll probably not update it as it's some volatile information especially if he has already fixed the problem
    – ce4
    Jun 27, 2012 at 22:18
  • @ce4 Yeah, I have edited and removed the linky :)
    – t0mm13b
    Jun 27, 2012 at 22:23

4 Answers 4


fastboot is when you enter fastboot mode, by powering up with volume up key pressed. Then fastboot devices would work.

Why are you invoking the recovery on its own via adb shell?

The recovery binary is reliant on the startup scripts used within the recovery partition unless the partition is messed up.

Recovery only works by powering up with volume down key pressed at the same time.

The vital details are missing from the question. :)

  • What device are you trying to fix up in respect to getting into recovery?
  • How did it happen? What did you do?

I had a very similar problem. For me, what worked was plugging in the device, typing adb shell to load up a shell on your device, then - this was my last resort, use only in emergencies ;) - running wipe data followed by reboot. My tablet rebooted and, though it had lost all of my personal data, I could now access it. Hope this works for you!


what version of android? 4.0? I just came across this myself, but when I try to run just about any command as root from the shell.

I have found some threads that talk about it being a permissions issue with su and it says to chmod it to 06755 but that didn't correct anything for me.

you can try running

$ strace recovery

and see if that gives any information on what is going on.

you can also try

c:/> adb reboot recovery

and see if that allows you to reboot.

  • Already tried adb reboot recovery and it doesn't work
    – Vandell
    Apr 28, 2012 at 18:36
  • Got this new messages 139|root@android:/ # strace -o logupdatepackage recovery --update_package=/sdcard/ginger.img covery --update_package=/sdcard/ginger.img < umovestr: I/O error
    – Vandell
    Apr 28, 2012 at 18:40
  • Unfortunately, I can't test it anymore because I got a replacement
    – Vandell
    Jun 27, 2012 at 22:45

Your system is corrupted, so you'll not be able to run adb just now.

First assure you have installed your device drivers (look here if you're on linux) and fastboot works.

Then you can use fastboot commands to try solutions

# allow writing the bootloader
fastboot oem unlock

# run a wipe
fastboot -w

# ensure user partitions are clean
fastboot format cache
fastboot format userdata

# a reboot here doesnt hurt (are you luck? let it enter in the system)
fastboot reboot

# if not, you still can flash images (if you have one)
fastboot update firmwareupdate.zip
fastboot flash system systemdevice.img

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .