1

i need help, with google contacts.

The phone is using google contacts and dialer (Android 9). I want to import contacts TO PHONE, but google contacts app allows only import to gmail acc.

Is there some solution? I do not want to use google servicies for syncing and storing my contacts, calls and messages.

Thank you

4
  • Import your contacts from vcf files: f-droid.org/en/packages/am.ed.importcontacts – Robert Apr 24 '20 at 17:57
  • Thank you. Sounds easy, but could google have access to the contacts? – Jimmyguitaro Apr 25 '20 at 20:12
  • If you have added an Google account on that device you can configure it in the account settings what should be synchronized. This allows you to disable contacts sync. How effective this is if you want to prevent Google to see you contacts I don't know. – Robert Apr 25 '20 at 21:55
  • Vell, somehow i set that it save into device, I tried that app. import contacts, but it imported badly, and created multiple copies of one contact. – Jimmyguitaro Apr 27 '20 at 14:25
0

i have had this problem on some Xiaomi devices. even when added contacts offline (with MyPhoneExplorer) it switched automatically into google when device goes online. i bet it is the contacts app per design not allowing local contacts.

i ended up with 3rd party contacts app (like com.simplemobiletools.contacts)

1
  • Thank you. Well, it is exactly Redmi note 8 pro. I do not want to risk flashing to Indian ROMs to use manufacturer apps. I will try it, Maybe i will buy Pro version. – Jimmyguitaro Apr 25 '20 at 20:14
0

Partialy solved. - no need 3. party apps For Xiaomi devices with google contacts, google dialer, google sms. In settings turned off several google servicies permisions to these apps. After some warnings and problem with opening contacts app. Finally it opened, without option to choose google account.

Now in app were 2 options device and mi account. When importing contacts with using google contacts, i choosed: Device. Now contacts appear to be saved in mi account

After removing mi account from phone contacts were imported into device succesfuly. - again when logged in contacts were under mi account (so turn off sync)

Depends on device, some google servicies have to be turned back on beacuse of calling and sending messages - (could have different names)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.