0

first question here. I was using wifi normally on my phone. Then I turned it off and after some time turned it back again. Since then I can not access the internet. It's showing Connected(no internet access).

I tried to set the IP static. It did not work for DNS 192.168.200.1. No matter what IP I set with this DNS it does not work. Then used the 8.8.8.8 as DNS, now it's connected. But it is really slow, and the connection does not seem stable. Every time I have to reload google.com several times just to get the page.

The problem is specific to this device only. Other devices connected to the same network are perfect.

Can someone suggest me what should I do? Is this a router issue? Or is this my device problem?

I'm new in this area. So my knowledge is not so deep and you might have to explain things a bit more in detail for me to grasp the concept.

6
  • Have you tried removing ALL static IP's and DNS settings, and allowing DHCP to get to work for you? – NiallUK Apr 24 '20 at 8:08
  • You mean from the router? – omar jayed Apr 24 '20 at 8:17
  • Also restart the router. – CFCBazar com Apr 24 '20 at 8:50
  • @CFCBazarcom tried that, it was the first instinct, Did not help. – omar jayed Apr 24 '20 at 9:52
  • First change the DNS to the original like suggested in the other comment, you can see the original in a working device, set DHCP and all settings to their original and automatic values, restart the phone and wait 5 min. After that we can continue with the debugging. – CFCBazar com Apr 24 '20 at 10:12
1

You can use Airplane Mode to reset DNS.

Put the phone in Airplane mode. Wait about a minute. Power the phone OFF, then start it up, then Remove Airplane Mode and test. It should work.

2
  • Just for my learning, what's the logic behind these steps? Turning phone OFF and ON would definitely kill everything including netd which holds DNS server address and cache. In fact when WiFi is turned OFF and ON, or Airplane mode is turned ON and OFF, netd resets settings, fetches DNS server during DHCP handshake if applicable, invalidates cache, and creates a new network ID. So putting phone in Airplane mode, waiting for a minute, resetting phone, turning Airplane mode OFF... what difference does it make? – Irfan Latif May 1 '20 at 5:10
  • The operative measure is disabling Airplane Mode, waiting and turning it back on. Turning the machine off and on is just for good measure. This is what I have found to work from long experience with smart phones. – John May 1 '20 at 13:18
0

I just had this issue took me ages but clearing the data from the the google play store app solved it for me..

  1. Open your Android device's Settings app and tap "Apps" or "Apps & notifications."

  2. Select the Google Play Store app from the complete list of apps.

  3. Tap "Storage," and then hit "Clear Data."

Hope it helps someone else!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.