1

I have a Chinese tablet Genesis GT 7320 Androd 4.1.2. It is rooted using kingo. I changed the vold.fstab file on the / etc partition system to vold.fstab.bkp. The table was locked and did not start anymore. Action or recovery mode by pressing the power and volume buttons above. I have access installed on the macbook and access to the tablet through the adb shell. After running commands with busybox. I'm a layman and I took time to discover the adb and busybox commands. However, I can't access a / etc partition system to rename the vold.fstab.bkp file to simply vold.fstab. I saw on the internet that you need to mount a system partition. I tried several commands I found on the internet, but I didn't get results. Below are some of the directories I have access with adb shell. Can someone help me?

busybox ls

cache init.rc sbin charger mnt sys data proc system default.prop res tmp dev rk29-ipp.ko ueventd.goldfish.rc etc rk29-ipp.ko.3.0.36+ ueventd.rc init rk30xxnand_ko.ko.3.0.36+ ueventd.rk30board.rc init.bootmode.emmc.rc rk30xxnand_ko.ko.3.0.8+ init.bootmode.unknown.rc root

busybox ls /dev/block

loop0 loop5 mmcblk0p2 mtdblock10 mtdblock6 loop1 loop6 mmcblk0p3 mtdblock2 mtdblock7 loop2 loop7 mtd mtdblock3 mtdblock8 loop3 mmcblk0 mtdblock0 mtdblock4 mtdblock9 loop4 mmcblk0p1 mtdblock1 mtdblock5 platform

busybox ls /sys/block

loop0 loop4 mmcblk0 mtdblock2 mtdblock6 loop1 loop5 mtdblock0 mtdblock3 mtdblock7 loop2 loop6 mtdblock1 mtdblock4 mtdblock8 loop3 loop7 mtdblock10 mtdblock5 mtdblock9

  • mount -w /system then rm /system/etc/vold.fstab and mv /system/etc/vold.fstab.bkp vold.fstab (with busybox prefix maybe) wikipedia.org/wiki/List_of_GNU_Core_Utilities_commands (please also read Related questions on the right) man7.org/linux/man-pages/man8/mount.8.html – alecxs May 6 at 22:34
  • The system showed the following message when I used busybox mount -w / system: mount: cannot read / etc / fstab: No such file or directory – José Roberto Gomes de Alencar May 7 at 0:01
  • which recovery do you have? check /system is already mounted with mount or df and remount it writeable mount -o rw,remount /system or find /dev/block -name system and mount -w <partition> /system – alecxs May 7 at 8:10
  • I used the guidance, but the system issued the following messages when I typed the commands below: # busybox mount -o rw, remount /system mount: mounting remount on /system failed: No such file or directory # busybox ls /dev/block loop0 loop1 loop2 loop3 loop4 loop5 loop6 loop7 mmcblk0 mmcblk0p1 mmcblk0p2 mmcblk0p3 mtd mtdblock0 mtdblock1 mtdblock10 mtdblock2 mtdblock3 mtdblock4 mtdblock5 mtdblock6 mtdblock7 mtdblock8 mtdblock9 platform – José Roberto Gomes de Alencar May 7 at 17:28
  • 1
    Congratulations!!! It worked!! Thank you very much for your help. – José Roberto Gomes de Alencar May 8 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.