4

I'm an iPhone user. Sorry for that.
But in my defense, I was given a recent Android phone and like it!

However, I noticed a difference in the Auto-Lock behavior that is, to me, utterly annoying.
Maybe people here used to the thing might enlighten the poor iPhone user that I am.

  • On an iPhone, about 10 seconds before entering auto-lock, the screen dims. Same on Android.

  • Then, tapping anywhere on the iPhone screen before the lock occurs, the dimming stops, the iPhone is ready to be used again and that's it. The location where the "tapping" took place is not activated. It's simply ignored.

  • However, on Android, while the screen is dimmed and one can barely see where the tapping takes place, the "tapped" location is activated! So whatever was tapped is run!

Most of the time, tapping the dimmed phone is just to wake it up. So, I tried to educate myself, and find an icon-less area to tap whenever I want to wake up the device. But sometimes it's within an app...
Compared to the no-brainer action on an iPhone, that's really annoying.

Searched the settings, the iPhone behavior does not seem to be possible on an Android phone.

This is the reason I wouldn't switch to Android. Most probably, Android users are used to that behavior and do not care (/ don't know that the behavior could be different).

Is there a way to set that iPhone behavior on Android?

4
  • It's the default behavior and I don't know if it can be changed. You can try an app to prevent screen from turning off when you need or switch to default behavior. There are plenty of other apps which offer an alternative (search for "tap to wake up screen") but they don't actually do what you want or apps like this
    – beeshyams
    Commented May 9, 2020 at 11:40
  • 1
    that is exactly why I don't tap the screen and scroll to wake the screen up Commented May 14, 2020 at 8:09
  • As Pouya Danesh suggested, instead of taping try swiping up/ down, it will wake up without registering any tap.
    – digiwizkid
    Commented May 14, 2020 at 9:35
  • @PouyaDanesh A simple no-brainer less error prone simple tap solution would be better, but thanks for the workaround, not ideal, but better than nothing.
    – Déjà vu
    Commented May 14, 2020 at 9:46

1 Answer 1

0

You can try the sleep option. You can do this by going to settings>display>sleep and then choose an option according to your preference. Some phones(like Redmi or Mi phones) come with a never sleep option whereas others can stay awake for a maximum of 30 minutes.

1
  • 1
    Thx. The problem is not the time-to-sleep, it's the "dim-wakeup".
    – Déjà vu
    Commented May 13, 2020 at 15:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .