I'm wondering if there is a way to record microsoft teams meeting with a smartphone; I'm using a motorola moto g6 play and the record button doesn't appear.

I tried with a screen recorder, but android doesn't allow to record internal audio unless you root your smartphone (in this case the warranty goes away).

EDIT: screenshot after clicking on three dots


Thank you in advance.

  • I have an explanation to why the recording button might not appear on your app: The administrator of your team might have disabled the option to record the meeting. Are you able to record meetings on other devices? May 13 '20 at 12:32
  • Hi @MehulArora, yes i can record the video by using a laptop. May 13 '20 at 14:56
  • Have you tried clearing the cache and data of the app? May 13 '20 at 20:51
  • @ReddyLutonadio how can i do it? I found only a video to do it on laptop. May 13 '20 at 21:10
  • Go to Settings -> Apps (or Apps & notifications). Look for Teams, select it. Under storage, select clear data. All data from Teams will be cleared from your phone. Restart the app (it will be as if you are using it for the first time). Select your account and give the necessary permissions. Try joining a meeting and check if the problem persists. May 13 '20 at 21:29

To view the recording button after joining a meeting, click the 3-dot then on the list that appears, you should be able "Start recording". Clicking it will start recording the meeting just like on the desktop app.


  • Hello @ReddyLutonadio, thank you for your reply. The strange thing is that on my smartphone there isn't the function "start recording"...i'll upload a screenshot as soos as possible. May 9 '20 at 20:43

Possible causes -

  1. Hopefully the reason is not this one, but anyways; an answer on Quora reads:

If you are trying to record in a private team channel, then you cannot record the meeting, as the team owner ideally disables the recording option for security purposes.

  1. Another answer:

This is an issue with the version of your teams. You can check for system or app updates and then try recording again.

  1. Another:

Teams meeting recordings are currently disabled for customers whose Teams data is stored in-country, if Microsoft Stream is not available in that country. A new admin setting will allow customers to turn on meeting recordings if Microsoft Stream data residency is not yet in country.

You can try clearing app cache, app data, reinstalling and updating your app if an update is available. Else, with the technical restrictions you have, I find it difficult for myself to cook a solution.

I'd always prefer going root. I know your warranty will terminate if you root the device; plus no point in potentially soft-bricking a smooth-running device just to have been able to record meetings. But rooting offers you so many tweaks that given a choice, I'd surely make the bargain. I think there are ways to delete the flash record from a device too; so there should be some way to keep the warranty intact


A solution is to open Microsoft Teams in the browser and here the record button is accessible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.