So I am trying to unlock the bootloader on my Xiaomi Redmi Note 7 and therefore I need to have access to adb and fastboot.

I'm very frustrated because I couldn't find a solution within the last 3 hours. My device just isn't getting detected by my computer when it's in fastboot.

I have tried so far:

  • Reinstalling Google Drivers
  • Downloading Xiaomis drivers
  • Disabling drivers signature
  • Using a different PC
  • Using 3 different USB Cables (including the original one)
  • Using different USB Ports
  • Using Linux Ubuntu

In all cases, my PCs just don't seem to recognize my phone in fastboot. I have enabled USB-Debugging and a adb works perfectly. Standard configuration for USB-Connections is data transfer. But as soon as I put my phone in fastmode manually or by adb reboot bootloader it just doesn't work. It does not seem to be a driver issue. When in "normal" ADB mode, it's showing up as a normal Android device without any errors (in device manager and "adb devices"), when in Fastmode it doesn't show up at all. Windows say the device is disconnected and there are no other unknown or faulty devices which I could try installing drivers for. fastboot devices just returns nothing.

What I mean is, it doesn't show up in fastboot devices or in Windows device manager or even lsusb in Linux.

I'm just desperate at this point. What am I supposed to do? Thank you very much for any help...

  • Just to make sure: Does the device in any USB mode work normal (shown as offline in adb devices is not normal). E.g. can you successfully copy files via MTP to or from the device? If not something general is wrong with the USB port of the devices (the other USB components like cable, computer or USB port you have already checked).
    – Robert
    May 15, 2020 at 7:20
  • Yes, when it's turned on anything works perfectly fine. It is recognized by windows, I can access files and it's showing up as an adb device
    – Rudolf
    May 15, 2020 at 7:25
  • android.stackexchange.com/q/214930
    – alecxs
    May 15, 2020 at 7:37
  • This doesn't really help me
    – Rudolf
    May 15, 2020 at 7:44
  • 1
    Hi @Matthieu I'm sorry but I have never found any solution for this. It seems to be an issue on the hardware level with the/my phone since fastboot works with every other phone I've tried. Sorry for the bad news but it seems to be an issue that can't be fixed by drivers or a reset
    – Rudolf
    Dec 16, 2021 at 20:09


You must log in to answer this question.

Browse other questions tagged .