I'm running Evolution X 4.3 (official) for Samsung Galaxy S6 (zerofltexx) with MagiskRoot and a few Magisk Modules. I was recently thinking about getting a custom boot animation for my phone, so I installed a root browser and looked for /system/media/ but it wasn't there.

I also tried the file manager built into TWRP, but I couldn't find it there either. When I tried to use the "Boot Animations for Superuser" app, it ran into an error trying to backup the existing boot animation.

If the /system/media/ folder is missing, how am I still getting the default boot animation that comes with Evolution X? Anyways, I just need help on how to replace the boot animation.

2 Answers 2


You should read the detailed text of the Boot Animations for Superuser app. There you can find the following info:

Q: Is my device supported?
A: Your device must be rooted to install a boot animation. Some manufacturers, like Samsung, use a different boot animation format (QMG) which is not compatible with this app.

Therefore the app does not work for Samsung devices. You need an app that is specialized to Samsung devices or that supports the QMG format.

And keep in mind the next section:

Q: The boot animation doesn’t play. How can I fix this?
A: Some Android devices use different install locations. You should find your current boot animation location and change it in the app’s preferences.

This explains why /system/media/ does not exist. Again, Samsung seems to follows a different path that most of the other Android devices.


I had the same problem with a Nexus 5, couldn't find /system/media using the file manager in TWRP - 3.7.0_9-0.

I solved the problem by go to Mount in the main menu and select System.

After that, I was able to see the folder normally using the file manager in TWRP.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .