2

I am trying to take kernel logs but so far have only got errors like 'permission denied', 'path does not exist' or 'kernel log does not exist'.

I have tried this kernel panic link, this crash logs link, this link that suggests how to take logcat and kernel logs simultaneously,the kernel log option in this secret menu, this link suggesting console-ramoops,this XDA tutorial and several other links.

List of commands tried:

  1. cat /proc/last_kmsg
  2. dmesg
  3. cat /proc/kmsg
  4. cat /dev/kmsg
  5. cat /sys/fs/pstore/console-ramoops
  6. *#9900# (Samsung only)

I am doing this in response to a comment on this post of mine. Any suggestions?

Edit:

So I have been able to get logs using *#9900#. The kernel log option didn't work but I set debug mode to high, let the reboot happen and then used the inbuilt option to copy logs to storage. The device restarted and showed 'watchdog reset' after which I force restarted. Along with many other files, texts, logs, it has mention of /proc/last_kmsg in a txt file. I will see if it is useful and share in the original post.

  • @IrfanLatif I have just been successful in getting the required logs using option 6 mentioned in post. Your link looks interesting and I will give it a try too tomorrow. Thank you. – TheCommentWriter May 21 at 14:33

Browse other questions tagged or ask your own question.