1

I bought a huawei p30 for development purposes. So the first thing i did, it is enable development mode, enable adb over usb, then type adb devices... nothing!

When I enable adb over usb, the setting is not saved! If I go back, and then enter the developer menu, it's disabled again!

I found this workaround:

  1. Dial *#*#2846579#*#*
  2. Select background
  3. Select USB mode
  4. Select "Google mode"
  5. Open settings
  6. Find development options
  7. Enable ADB over USB.

Now it works... for a little while! Just unplug the cable for 1 second, and I need to repeat all the steps again! ADB disabled, USB mode reverted to "huawei mode", and so on! This is ridiculous! I bought this device for development purposes, it should have a permanent way to enable adb, as expected in each single Android device since version 1.0. How devs can debug huawei devices if each time enabling adb is such an hassle???

I must be missing something, how to permanently enable adb on (newest?) Huawei devices?

  • There are apps in PlayStore that can directly open Development Option page. Not sure if they work on your device but worth a try as this would reduce the number of necessary steps. Another option would be not to disconnect the device from USB. – Robert May 23 at 11:22
1

I was using Huawei mate 10 lite, as I remember I had fixed this issue by selecting Allow ADB debugging in charge only mode at developer options section

| improve this answer | |
  • It works! Thanks! I did not imagine that it was somewhat related – Magnetic_dud May 26 at 13:12
  • me too :) you are welcome – haliltprkk May 27 at 6:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.