I have a Samsung S9 running Android version 10 (q). I frequently use the Google speech to text facility on the keyboard. I can make it do punctuation like commas and periods however I cannot make it do a new line or carriage return. There seems to be posts about very old Android versions showing that this may have been possible. is this still possible please?

  • Ok. Have you tried those old posts you encountered? Old does not mean obsolete. :-)
    – Firelord
    Jun 2, 2020 at 9:13
  • 1
    Ah good point. Yes I have tried them and it doesn't seem to work as it once did. Seems such an obvious functionality to have. I can't understand why it doesn't work now.
    – user324588
    Jun 2, 2020 at 21:11

2 Answers 2


On Android 12 with a Google Pixel 6 and Gboard voice typing, the voice command is "New line".


I have the same phone, Samsung Galaxy S9, with Android 10, with the same problem. When I said, "new line" or "new paragraph," these phrases are not typed. If I say them after a period, a space is generated. If I say "period new paragraph," just the period is generated. Changing the language settings to single language or disabling, "Block Offensive Words" does not affect it.

In Google Play Store, I updated "Speech Services by Google" and rebooted. After that I got, "new paragraph" to work. I'm not sure if I didn't just get the pause to be an appropriate length. It works even without a comma or period. It seems that it needs to be said as if it were written in italics.It doesn't always work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .