0

The apk im trying to get to work is exagear 3.0.1. It is the one with which you can get some things running on windows, including what i want to run but things I want to run are too big filesize to stay on my internal memory. Exagear is Wine based but dead project, whoever worked on it left it. Few tried to modify it by adding with extra MS frameworks but not proper access to all your folders.

Exagear browses only your internal memory's Download folder, you cant even see dcim, pictures, etc all these common folders. Now I saw on a youtube video in spanish someone made some exe shortcut that works for older version but the Exagear version 2.9 crashes when start and obviously isnt a working version. I use an English version and 3.0.1.

An unpacking the apk shows the Mainfest has the WRITE_EXTERNAL_STORAGE which helps, nothing, nor if I added READ_EXTERNAL..

I have Magic Dosbox which asks you to grant access to folders, and when you do it from the program, it is added as Special apps access (using Android 9 Pie btw). I thought I needed to do same w Exagear.

I pulled data/system/urigrants.xml and added the line

<uri-grant sourceUserId="0" targetUserId="0" sourcePkg="com.android.externalstorage" targetPkg="com.eltechs.ed" uri="content://com.android.externalstorage.documents/tree/9C64-18E6%3A" prefix="true" modeFlags="3" createdTime="20482846090" />
</uri-grants>

great, that adds it to the list of Directory access (under Special apps access) just like Magic Dosbox. Alas, still see only root folder with mnt, storage, and in storage/emulated/0/Download

External SD card is usually storage/30D0-DS35 can be like that, instead of name that says 'external sd'

ADB shows me as I can access this folder just fine but Exagear refuses to show any other folder. Losing patience with this, any1 knows whats needed?

  • 2
    uri-grant is the permission granted to an app built with Storage Access Framework. Such apps explore the directory tree through Android APIs, not at filesystem level. If your app isn't built with SAF, what you are trying to do won't work. Even at filesystem level apps cannot write directly to whole external SD card under normal circumstances: android.stackexchange.com/a/218338/218526 – Irfan Latif Jun 3 at 0:34
  • No problem me looking at the wrong way. Im looking for any way to make it work.So I have to look at option 2 from that link with Binding? I have to bind e.g. the external sd folder to storage/emulated/0Download/? how would this look and do I need any special way to make it permanent for this app? im new to this so im not sure – programc7r Jun 4 at 12:48
  • Yes with root access you can bind mount a directory from external SD card to some directory in /sdcard. Bind-mounted directory will be accessible to all apps with Storage permission. See How to bind mount a folder inside /sdcard with correct permissions?. Another hack is to map WRITE_EXTERNAL_SRORAGE permission to GID media_rw (1023) so that all apps can write to external SD card. But if your app itself doesn't write to external SD card, the second hack will be of no use. – Irfan Latif Jun 4 at 12:56
  • I opened the Manifest.xml of the apk it has the WRITE_EXTERNAL_STORAGE permission. In ADB shell im doing like su -mm -c 'mount -o bind "storage/30D0-DS35" "storage/emulated/0/download"' and it is mounted in ADB if I list download folder it is the External SD, but the Wine explorer in ExaGear still shows original Download folder. The original Wine apk itself can browse all folders and the external card without any special setup, yet exagear is stuck on this Download folder. winecfg is a file that allows setting up drive letters but no point setting one if it doesnt see the sd card folder – programc7r Jun 4 at 13:32
  • All issues you are facing are addressed in the linked question. Please go through the answer once or twice patiently. It won't be possible for me to explain everything again in comments. If you face some different situation, I'm here to help. – Irfan Latif Jun 4 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.