1

I have a tab S2 stuck on 5.02 I wanted to upgrade the software to lineagOS There are lots of information out there but nothing that can help me. A few things first that I need to share. Im usung a MAC I once unlocked my device and knox is now void so must be unlocked. the bootloader I cant tell if unlocked. using an app I tried to check but came back with an error of " Sorry! root access is not properly installed on this device" The tablet is in developer mode, there is no OEM mode or anything like that, usb debugging is turned on. I have tried several things using terminal but didnt work with home brew an adb services. these installed on my mac but got as far as trying to add fastboot devices but denied on the terminal, but that probably makese sense if the bootloader is locked.

MOst insgtructions imply that you know what to do and dont exxplain much. Can anyone please assist with step by step instructions so I can complete the process of installing LineageOS.

Id appreciate your time if you can help me.

KInd regards

5
  • Have you looked at the instructions in the LineageOS wiki? They are pretty step-by-step, up to telling you which keys/buttons to press when to achieve what.
    – Izzy
    Jun 4 '20 at 20:50
  • 1
    @Izzy: The right idea but the wrong link ;) This link should point to the correct device: wiki.lineageos.org/devices/espressowifi However the Tab S2 is no longer maintianed by LineageOS, hence you won't find any official LineageOS builds anymore.
    – Robert
    Jun 5 '20 at 7:16
  • you may still find old builds somewhere android.stackexchange.com/q/213272
    – alecxs
    Jun 5 '20 at 8:06
  • @Robert Oh, I missed "tab". Wasn't InitCapped so I didn't recognize it as part of the name #D Apart from that: It's a Samsung device, so steps might be comparable. But maybe better check with one of the other tabs then which are close to that. I'm not a Samsung user, so I cannot really tell which ones that might be…
    – Izzy
    Jun 5 '20 at 13:43
  • Thank you for all you advice. Ive tried looking on lineageOS couldnt find anything to help. I'm not sure what download mode is to check bootloader status. if Tab S2 is no longer maintained by LineageOS is there no hope, I want an update as near as possible for the tablet. 5.02 is very old
    – Ronin_999
    Jun 5 '20 at 17:33
0

Samsung devices does not have fastboot mode, at least i am not aware of Samsung devices with Mediatek chipset

the bootloader lock status can be checked only from download mode screen

step by step instructions vary on device and android version. your android version 5.02 may not have OEM unlocking in developer options, you can skip this step

on the other hand be aware Samsung does improve security continuously and may roll-out new features even to old devices, which leads in non-working tutorials

also rooting apps like Magisk do silently change usage at will which may end up in data loss if tutorial isn't up to date

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.