1

I wanted to root my redmi y2 device. I have unlocked my bootloader and successfully flashed Twrp recovery from adb however it's touch screen is not working, probably because my device doesn't supports touch screen in recovery mode as it also uses volume keys to navigate in it's stock recovery.

Is there any other custom recovery which uses volume and power keys to navigate or can I give command from adb or anything else to flash magisk in recovery mode with my pc only or just any other method to root my phone.

I have already wasted hours and hours serching on the web to resolve the issue, also I have tried different versions of Twrp but again no luck. Please help me out, thanking you in advance.

3
  • Stock recovery always uses volume keys for navigation. According to the TWRP device list your device is not supported. Which version did you flash? Each TWRP version has to be the correct one for your device otherwise some hardware components may not work as you have encountered with the touch controller.
    – Robert
    Jun 10, 2020 at 10:57
  • @Robert I had used an unofficial version of it posted on xda TWRP unoffical for redmi y2. Ok I think being unofficial is the only problem. Jun 10, 2020 at 11:57
  • 1
    @alecxs thankyou too much, flashing orange fox recovery worked for me. Sorry I didn't noticed that this TWRP was not for MIUI11 Jun 10, 2020 at 20:20

1 Answer 1

1

Orange fox recovery should be flashed in case if you are using MIUI 11. Link to that can be found here. For MIUI 9 and 10 users this TWRP is working fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .