After upgrading to Android 10, I am not able to use the Files app to view local files on my phone. If I run Files and view the Downloads folder, for example, it merely says "Can't load content at the moment".

I've been using the built-in Files app for many versions of Android. But after upgrading to Android 10 it stopped working. I am able to view the contents of some directories. And if I choose / navigate to folders in a different way, e.g.

  • Images -> Download Or

  • Device -> Download

Then the file explorer will view some files. But simply selecting "Downloads" from the menu gives me this error.

I have gone into App Permission -> Storage, but the Files app does not appear there. Inside App Info -> Files it says "No Permissions requested". I have installed two other file browsing apps, and both of them can access all of my folders just fine.

Is there something I'm missing to be able to browse my own local files, on my own device, using the OS built-in file browser?

  • 1
    Thanks to Scoped Storage. That's expected. Commented Jun 13, 2020 at 23:05
  • I'm having the exact same issue! Folders with lots of files, such as Download or DCIM/Camera, simply do not load. Neither on Files nor on an external file browser. But accessing via Images or Downloads on the files app sidebar, or through the Gallery, does work flawlessly. Surprisingly, going through root and /data/media/0 on an external file manager does open every folder instantly!
    – andrepd
    Commented Oct 31, 2022 at 17:21

2 Answers 2


As pointed out in comment, this is because of Scoped Storage introduced from Android 10.

Before Android 10, any app could read or write any files to external storage (the place where apps store their data), if they requested the READ_EXTERNAL_STORAGE and WRITE_EXTERNAL_STORAGE permissions. Starting from Android 10,apps can only access data created by them and not other app's data or common data like images, downloads etc.

This enhances your privacy and is a good thing. Apps can access only data created by them and if they need access to external storage they need to access it using Storage Access Framework (SAF) . The file manager you are using isn't seeking permissions through SAF, so it can't read while other file explorers you installed can because they use SAF. Apps like Local Storage may help for using SAF when they don't employ this.

Aside, for those users who are rooted and would like to address the security concerns of apps reading data created by other apps, they can try Storage Isolation Magisk Module or XPrivacyLua also provides a solution by blocking app read/write access to the SD card completely (using the Privacy.BlockGuardOS.open repo hook) or by limiting access to the app's private directories (/sdcard/Android/data/app-id and others, using the Fif.BlockGuardOS.open repo hook).


Just came across this same problem on a Galaxy Tab S4.

Fixed it by clearing the data of the system 'Files' app (Settings > Apps > Show system apps > Files > Clear data).

  • Are you running Android 10 or above? Otherwise, the answer might not be helpful to OP.
    – Firelord
    Commented Feb 1, 2021 at 9:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .