1

I flashed PixelBoot's unofficial LineageOS 17.1 on Nexus 6P, however I failed to root it.

First I tried flashing Magisk-v20.4.zip, which failed w/ "cannot mount /vendor" error. Here suggests I should upgrade TWRP to a "Treble compatible version" but my TWRP is already the latest 3.3.1-0.

Secondly I installed MagiskManager-v7.5.1.apk to see if I could use the "patch boot.img" approach. But it kept "checking for updates" till the end of the world, not showing the "install" button at all. I should probably opt out of the canary channel, however I am already in the stable channel.

Thirdly I looked for LineageOS's su addon zip. Unfortunately they offer that kinda thing for 16.0, 15.1 and 14.1 only.

As the last resort I flashed SuperSU-v2.82-201705271822.zip and installed supersu-2-82.apk. But the latter just fails to detect the former and refuses to work.

How am I supposed to root my phone?

It it because of the incompatibility between Android10(LOS17.1) and TWRP?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.