1

I am trying to root my Google Pixel 3a with Android 10. The bootloader is unlocked. It says so in the dev settings, and I have to go through the warning prompt every time I reboot my device. I am following these instructions for rooting it(using method 2). When I run the fastboot command to flash the patched .img file, it returns:

C:\Users\MyPC\Android>fastboot flash boot_2 magisk_patched.img
target reported max download size of 268435456 bytes
sending 'boot_2' (30392 KB)...
OKAY [  0.798s]
writing 'boot_2'...
FAILED (remote: Not allowed to flash (boot_2))
finished. total time: 0.861s

I tried without the "_2" which also does not work. I used fastboot getvar current-slot to determine which partition is correct.

Things I've tried to troubleshoot:

  • Running cmd as Administrator (im using win10)
  • Confirmed OEM unlocking is turned on in the dev settings (it is, it says "bootloader is already unlocked"
  • Confirmed USB debugging is on
  • Disabled "Verify apps over USB" and "Verify bytecode of debuggable
    apps" in the dev settings.
  • Confirmed file transfer is enabled from my PC and my Phone (it is, I can transfer files back and forth between them)
  • Tried a different USB cable
  • Having "OEM Unlocking" turned on does not unlock the bootloader, it gives you the ability to unlock the bootloader and it doesn't appear you have actually unlocked it... On the fastboot/bootloader screen, does it show Device State as Locked (in green) or Unlocked (in red) or perform a "fastboot oem dmesg" and it will either output information (unlocked) or state "not allowed when device is locked". If you unlocked, you have entered "fastboot flashing unlock" and had to accept a very "nasty" warning, as well as a factory default. You know when you are unlocked... – acejavelin Jun 20 '20 at 14:01
  • 1
    slot is usually a letter (not a number) like boot_a. try unlock_critical also make sure AVB isn't a showstopper (vbmeta) – alecxs Jun 20 '20 at 14:06
  • @acejavelin On the bootloader screen it says Unlocked (in red). I brought up the OEM unlocking for extra clarification. I ran "fastboot oem dmesg" and it output information. I do know that I'm unlocked, which makes it more confusing why im getting a "not allowed to flash" error – Gunner Jun 20 '20 at 14:11
  • @alecxs Yep, that was the problem. Thank you – Gunner Jun 20 '20 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.