1

I've found my Xiaomi redmi note 4 stuck in fastboot mode after the battery had died. I tried different ways to unbrick it but nothing helps. The list of ways I tried:

  1. platform tools fastboot binary. fastboot reboot bootloader - still rebooting to fastboot.enter image description here says I can unlock it but... Also, adb binary doesn't recognize my device.
  2. I can't use mi unlock tool because it doesn't see my phone.
  3. Miflash doesn't recognize the device also.

Are there any other ways to unbrick it?

Edit: It's Mediatek Helio X20

4
  • If your device is in bootloader/fastboot mode then adb does not work that is by design: android.stackexchange.com/a/225159/2241
    – Robert
    Jun 22, 2020 at 7:05
  • first i would try is, in fastboot mode keep holding Volume Up while fastboot reboot and release button when in recovery mode. there you can wipe cache
    – alecxs
    Jun 22, 2020 at 13:08
  • @alecxs still rebooting to fastboot. Do you know if there any mac os drivers from the examples above? Jun 22, 2020 at 13:15
  • flash boot recovery system from SP Flash Tool. make sure you have the right scatter file. always flash with golden rules: "Download Only" + never flash preloader
    – alecxs
    Jun 22, 2020 at 20:01

1 Answer 1

1

The problem was not in fastboot mode. The reason was that my volume button was shortening and was always pressed. Fixing the button solved the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .