1

I am trying to start learning how to develop Android apps, and I tried to make a new project and navigate through Android Studio. I tried using the Emulator by creating a new virtual device and running my new test project with it, but no matter what i seem to do it never actually does anything once I click the "Run" button on both the AVD Manager and the main one you see on the top right area of Android Studio.

id

I keep seeing this after i try to click the Run button again after not seeing anything happen. and i can't seem to delete any of the files this is pointing to since Windows keeps complaining its being used by another application even after I close Android Studio and terminate adb.exe

I've been looking around for an answer and i've found things like "Uncheck Enable ADB Integration", or "Changing the Emulated Performance Graphics to Hardware/Software", but a lot of these answers are from threads that are 3+ years old so I don't think these are applicable anymore. can someone provide some insight to how to get this working? I am using Android Studio 3.6.3

PS: I want to make it clear that even after i restart my pc and delete these so called "*.lock" files, this changes absolutely nothing

EDIT: As requested here are some screenshots that hopefully answers some questions I was being asked.

My PC specs: enter image description here

Android Virtual devices i have set up so far: enter image description here enter image description here enter image description here

my installed SDK Tools: enter image description here

As for the BIOS Virtualization question, if "Intel Virtualization Technology" is the same thing then yes it seems to be enabled for me

3
  • Please edit your question and add more details e.g. what emulator image you have chosen,what CPU your system has, have you enabled Virtualization in your BIOS, have you installed Intel Haxm or the "Hypervisor driver for AMD" package provided by Android SDK Tools? If you are a non-commercial user you can try Genymotion emulator. It works very well and is simple to use. – Robert Jun 29 '20 at 7:25
  • Am i not limited to Android Studio's emulator? Is it possible to use Android Studio purely for writing/compiling reasons and an external emulator like this so called "Genymotion" an, option? Never the less I will update my question to contain answers to your questions – user3696118 Jun 30 '20 at 17:51
  • For Android Studio it does not make any difference if it is a real device, an emulated device from SDK emulator or a Genymotion emulator. They all are just ADB devices. – Robert Jun 30 '20 at 20:15
0

following Robert's advice I opted to install a copy of Genymotion Personal Edition and linked it to Android Studio via the Genymotion Plugin that was available to install.

see here for installing: https://www.techbeamers.com/genymotion-emulator/

If you do not see an additional icon pop up like described in the page then you will want to (in the case of versions around 3.6.3) enable the Toolbar via View>Appearance>Toolbar

This seems to at least link up fine for me with Android Studio, but overall does not really answer the question as to why the emulator via AVD does not function.

If no one seems to be able to share that knowledge, then I suppose will pick this one as the best answer.

Thanks to Robert again for mentioning Genymotion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.