A few days ago I've updated my rooted(with magisk) galaxy s10(SM-G973F) to the latest firmware(patched with magisk) of ILO(G973FXXU7CTF1 - my previous firmware - G973FXXU4BTA8 - had one ui 2.0), and it seems that since then, it is pretty much bricked.

GBWhatsapp Mini doesn't work anymore(can't download media), Google Play tells me Netflix and a bunch of other apps are "not compatible with your device" and I can't connect my Galaxy Watch anymore(stuck on pairing).

I've previously tried to upgrade it to G973FXXU4CTC9 and had the same issue so I've downgraded back to G973FXXU4BTA8 and it was all fixed, but now it won't let me even downgrade(SW REV CHECK FAIL)..

What can I do then?


  • you have upgraded bootloader from U4 -> U7 – alecxs Jul 1 '20 at 14:25
  • @alecxs correct. Is it related? – Ben Yaakobi Jul 1 '20 at 15:54
  • you can't downgrade bootloader so you can't downgrade ROM – alecxs Jul 1 '20 at 17:26

Eventually solved it...

The Galaxy Watch thing + the Netflix thing were solved with this combination(not sure which of these steps solved it):

  1. Installed MagiskHide Props Config module and blocked the following using Magisk Hide:

    • Galaxy Watch Plugin(all)
    • Galaxy Wearable(all)
    • Google Play Games
    • Google Play Music
    • Google Play Services for AR
    • Google Services Framework
    • NFC
    • Samsung Health
    • Wearable Manager Installer
    • Google Play services(com.google.android.gms and com.google.android.gms.unstable only)
    • Google Play Store(all except com.android.vending)
  2. Ran these commands as root:

mount -w -o remount /vendor
cp --preserve=all /vendor/etc/vintf/manifest.xml /vendor/etc/vintf/manifest.xml.bak
sed -i /`grep wsm /vendor/etc/vintf/manifest.xml|sed 's@/@\\\/@'|sed 's@>@\\>@g'|sed 's@<@\\<@g'|tr -d ' '`/,/'<hal format="hidl">'/d /vendor/etc/vintf/manifest.xml
mount -r -o remount /vendor
  1. Installed Bluetooth Library Patcher module

Now the GBWhatsapp Mini problem. For some reason it required that Install unknown apps permission would be allowed for it.

Now everything works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.