I have Magisk 4.20 manager and installed the fbind module. I need to use it properly because I made a small mess: I just wanted to bind a folder on my external sd with Download from internal memory. I used fbind -b

[Topic 1- solved] but now some new folders were made that i cant delete mnt/runtime/read/emulated/0/mnt/media_rw/MD6H-KDY5/My Folder and mnt/runtime/read/emulated/0/mnt/runtime/write/emulated/0/download This as explained Why deleting system files on a rooted Android says "device or resource is busy"? but if I enable core modules, delete the folders, then disable core-only modules, remove fbind and reinstall fbind, the folders are BACK...

So what I need to unmount to remove permanently from seeing them each time, they are wrongly made.

Edit: Final solution was to put (overwrite) some empty config.txt in data/adb/fbind and then I can delete the folders, it seems to read it from there. So no need to switch to Core only in magisk or uninstall the fbind.

[Topic 2 - unsolved] And I need to bind correctly w fbind like bindfs after I delete these extr folders, where I see content of External card as the download folder, till I revoke the bind. So what is the correct way to use fbind, it creates its own folders .fbind unlike bindfs . I like bindfs better but it only worked within terminal app on phone, other apps cant see the link.

What is the command? So that I do it like how I do with bindfs

  • I never used fbind but you can use bindfs directly: How to bind mount a folder inside /sdcard with correct permissions? Jul 3, 2020 at 16:09
  • THE reason why I dont use BINDFS unless fixed is I need to make it work ON PHONE no ADB, NO PC connection, with those the bind gets lost probably even after the phone lock screen, not only reboot etc. I do it no Terminal Emulator and when I LS the Download folder yes it is showing the content of External SD but outside of it, apps dont see it. It worked with ADB and bindfs, then even File Explorer app will see External SD content on Download but as I said gets unbinded easily and I need to do it away from PC
    – programc7r
    Jul 3, 2020 at 16:21
  • You are stuck with mount namespace and other minor problems. Read the answer, everything is addressed in detail. Jul 3, 2020 at 16:38
  • I read these few times. Ok I found android.stackexchange.com/questions/197959/… I used MagiskSettings to set Mount Namespace Mode to Global then ran command in Terminal, now File Explorer sees Download folder with external SD files good. But I use ScanMediaPlz and Exagear app still sees Download as empty even when File Explorer now sees the mounted drive. How it worked when I do it via ADB but cant from here. I cant use u:object_r:fuse:s0 it still cant recognize context
    – programc7r
    Jul 6, 2020 at 14:47
  • Ok it worked finally, thanks. Dont know why at first app didn't see external SD files in Download but now it does.
    – programc7r
    Jul 7, 2020 at 10:15


You must log in to answer this question.

Browse other questions tagged .