3

My Gionee A1 plus started acting strange a month ago. It would often restart whenever I received any SMS notification and then boot up just fine. I tried using an earphone and keeping the phone in silent mode, as reducing the notification sound levels didn't help. This fixed the problem for a few weeks until 2 days ago while using my camera, it suddenly decided to restart but got stuck in a bootloop(the boot logo kept popping up and disappearing again and again). I managed to turn it off by plugging it to a charger where it went to charging mode.

After a bit of research, I entered the stock "Android recovery mode" and cleared the /cache partition but that did not fix the issue. I panicked as I did not have a twrp or any other recovery tool installed. I didn't even have USB debugging enabled. However, after a bit more strolling I found that fastboot could detect my device(after rebooting to bootloader) and then ran the command fastboot continue and my phone booted up alright. But now my phone can't use the "Ultrafast charge mode" which makes the charging process 5 times longer and the battery drains really quick. What's more the phone restarting by itself has become often(I can't even use my camera) and its always the bootloop. I have to use fastboot to boot in again.

I created a backup of my data and then did a factory reset on the device to no use.

Do I need to flash a stock ROM to my device or am I missing something? I am inexperienced in this domain so please guide me on how to fix this issue. I have attached snaps of my Recovery and Factory modes.

Recovery mode

Hardware details

fastboot commands

TLDR; phone ends up in bootloop after suddenly restarting while in use, battery drains faster, no ultrafast charging, clearing cache and factory reset doesn't help.

  • even more worse your backup is useless because you didn't backup metadata partition from SP Flash Tool. unfortunately this is a bug in android system recovery – alecxs Jul 5 at 10:46
  • Thanks for replying. I did run the root integrity check and it passed with no errors. I hadn't tried rooting my device before either. – Pankajkumar Jul 5 at 12:11
1

Did it suddenly started to do weird things? Can you specify the cause. As per the mentioned details, you need to flash stock firmware from SPFlash Tool(as you have a MTK device). You can google for your firmware. And flash it while your phone is in download mode. I too have faced many bootlops while flashing roms. So I flash stock firmware and all good.

| improve this answer | |
  • If I recall correctly, it started when I first started using meeting applications. Sometimes I would get an echo of background noise on the loudspeaker and the phone would reboot. Now the phone just can't store any charge or so it seems. Is it possible that it is a hardware problem of some kind? – Pankajkumar Jul 12 at 10:40
  • After flashing the stock ROM (SWW1617GI_0301_T5242 since I coudn't get the T6953 one) the system booted fine. But after I removed the USB cable the phone died. It wouldn't reboot anymore even if I flash it again. It doesn't even get to the recovery menu without being powered and fastboot continue doesn't help anymore. I'm beginning to doubt it's a hardware issue(probably the battery) somehow. – Pankajkumar Jul 21 at 14:44
0

It actually turned out to be a battery issue. After replacement, the phone works as good as new(or so it seems).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.