1

I just got a new samsung phone. It came with usb-c to usb-c cable and no adapters. I tried connecting it to my laptop, which thankfully has an usb-c port. The phone connects at first, starts charging. Then, whether I choose the option to "send files" or "send pictures", the phone disconnects after a few seconds or so.

It's really troubling.

My specs (just some of them, I will list more I missed anything important) Laptop is a 2017 gaming Asus. It has Windows 10 and usb-c port. Phone is the Samsung Galaxy S20 Ultra.

Some facts:

  • The phone is brand new, from a store, all sealed up.
  • It charges perfectly fine using the cable and a charger.
  • Connection over usb-c does NOT work - it keeps disconnecting, usually after a few seconds.
  • However, I can easily connect a pendrive using an adapter I had before. (I can send data both ways)
  • Using an old usb-c to usb-b cable to connect to my laptop through a different port ALSO works.
  • I get no messages or anything when it disconnects.

What could that mean? Is the usb-c port on my laptop possibly busted, or is there some driver / permission / program I need to use it?

  • 1
    I don't think that's the case - I use that new cable for charging and it works perfectly, no drops or even power loss. However, I think I found the solution and I feel stupid now. I will post it as an answer. – lilKriT Jul 6 at 5:39
  • 1
    If you mean the USB settings on my phone - "controlled by phone" and either "send files / android auto" or "send pictures". I apologize if the names are not perfectly translated, I use my native language on the phone so I don't know the english names (had to translate on the go). And I still don't know what are all the settings for, like "control by phone / computer". – lilKriT Jul 6 at 5:43
1

I feel stupid now, but I will leave the topic here in case someone has the same problem.

I decided to disconnect my USB hub which was using one of the usb-b ports. After I did that, the usb-c connection worked fine.

EDIT: Turns out things are even weirder. Apparently it doesn't matter if the hub is plugged in or not.

What seems to be the real issue is that after the phone connects and by default, it's set to "move files / auto android"... it's not really default. You have to change to any other mode like "move pictures" and then back to "move files / auto android". Seems to be working so far.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.