1

I have a Xiaomi redmi note 8, which runs on MIUI-11, I've recently unlocked my phone with MiUnlock, the official program of xiaomi to unlock (root) your phone. I've stumbled across a few hickupps, but eventually I got here, I can't get further though... I installed TWRP using the ADB terminal, wiped the cache, flashed a zip that disables force encryption treble and after that, I installed Magisk (I did this all with the compatible versions for xiaomi redmi note 8). Normally, I should've been able to just reboot to the system, but TWRP just comes back. When I reboot, I first see: Redmi by Xiaomi (screen 1) Then: Redmi Note 8 by Xiaomi powered by android (screen 2), this takes longer than it normally should, after that I see screen 1 again, and then again screen 2, whereafter I get the splashscreen from TWRP and it boots in recovery again...

I've already tried clearing the cache, enabling "System" in mount, tried to write this code in the advanced --> terminal option: dd if=/dev/zero of=/dev/block/bootdevice/by-name/misc bs=256 count=1 conv=notrunc Nothing helped me, one other weird thing that scares me is that, when I watch my folders with file explorer from windows, everything has gotten a random string as name... You can see it in my attachment. internal storage of xiaomi redmi note 8

I would be soo grateful if someone could help me out. Thanks for being awesome!

  • Is it an A/B device? Possibly you have flashed TWRP to boot partition. – Irfan Latif Jul 9 at 18:17
  • 1
    the force encryption disabler did break fileencryption. do a factory reset to remove encryption completely and stay unencrypted. or restore/repair your fstab to bring encryption back to working state – alecxs Jul 9 at 18:57
  • @IrfanLatif What do you mean with A/B device? I've looked it up and it has something to do with how updates are installed, but I don't really get it. I've just used the adb commands: adb devices --> fastboot recovery twrp.img --> fastboot boot twrp.img So I don't know where it normally gets flashed – DigitalGrzzly Jul 9 at 19:40
  • @alecxs Do you mean within TWRP itself? Or with mi flash or another desktop program? – DigitalGrzzly Jul 9 at 19:42
  • If I need to use wipe, which partitions should I wipe? System too? or only ART cache, Data, Internal Storage and Cache? – DigitalGrzzly Jul 9 at 19:50
1

If you don't need the data download the stock fastboot rom for your device and flash it.

From your comments above it looks like you've already wiped your data.

So I would suggest that you download the stock fastboot rom. Do a clean all flash. Don't do the clean all and lock flash, as it will lock your phone.

Once it's finished, you can flash twrp but don't try to disable file based encryption and then try flashing whatever other rom you were trying

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.