1

So I was trying to install Lineage OS (the unofficial version), because I think it works better with my phone. I already did that before, and I am not a newbie... But what I did today shows the contrary.

I downloaded everything on my PC and did a backup, and then I factory resetted my phone. After that, I activated the developer options and then the USB debugging and then I went straight into TWRP (I already flashed, I had a working, unlocked, MIUI ROM) and formatted almost everything (System, Data, Vender, etc, but not the USB option). I did something similar last time without any problems, so I thought this would be like the last time. But it wasn't.

After I did that, it sent me into Fastboot mode (kind of expected that), but when I tried entering some commands into the ADB console (like fastboot devices, or adb devices) it did nothing. The thing is, I tested it on my PC, and those commands were supposed to be working. I had the drivers and everything. I also tried to just flash back into the MIUI ROM (with the MIUI Flash tool), and it did nothing (it found my phone when I replugged it into my PC, but only for 3 seconds. Tried flashing and it didn't work). Also, I can't go into Recovery mode, it just sends me back into Fastboot mode.

I believe it's because of USB debugging not remembering my PC, even though I selected it to remember the PC. Also, I think the OEM is still unlocked, it has no reason to be locked as I did not enter any of those commands, I just... deleted my phone...

Any help?

5
  • android.stackexchange.com/q/224717
    – alecxs
    Jul 9, 2020 at 21:59
  • The PC doesn't detect the device. I can't flash anything on it...
    – naphy
    Jul 10, 2020 at 5:09
  • usb-debugging (adb) is not required for flashing. while in fastboot mode install proper usb-drivers. or use linux without drivers at all. download fastboot ROM and flash boot + system + vendor from fastboot. or boot into EDL mode and flash from QPST
    – alecxs
    Jul 10, 2020 at 7:21
  • Yep, it was a driver problem after all. Sorry for my misinformation, apparently the laptop I use doesn't have the drivers for fastboot (I think). I thought it would be like my last laptop which automatically had all the fastboot commands working as intended, so it never went through my head that it would be something with my laptop. Thank you for helping me! Have a good day!
    – naphy
    Jul 10, 2020 at 16:53

0

You must log in to answer this question.

Browse other questions tagged .