0

I have an ssl web app hosted on my home network that uses dyn-dns to maintain my public IP address and a CNAME record to point my actual domain name to the dyn-dns domain name.

This all works fine on my desktop machine (hosted on same network as my app), my wife's mobile (on same network again) and on 2 friend's mobiles on external networks.

On my mobile (A google pixel phone running latest android) when I go to the same address I get:

This site can't be reached

[domainName]'s server IP address could not be found.

DNS_PROBE_FINISHED_NXDOMAIN

I have tried flushing the cache in the chrome://net-internals page and I have deleted the application cached data for chrome. I have also restarted my phone.

How do I fix this??? It's very frustrating.

Many thanks in advance.

4
  • Have you tried changing your DNS settings? Since you have a Pixel, go to Settings - Network & Internet and open the Advanced section, then select Private DNS and Private DNS provider hostname and change it to one.one.one.one, dns.quad9.net, or just enable Auto to use Google DNS. – acejavelin Jul 12 '20 at 12:05
  • Are you using WiFi or Mobile Data? Or are you using some local DNS server? May be your domain is negative cached in some intermediate recursive server. So you have to wait for its TTL to end e.g. 24 hours. Use some DNS troubleshooting tool like dig on Termux to check what it returns. Better use doh to bypass any caching server. My previous answers which may help: How does Android OS do DNS name resolution? and How to reliably clear DNS cache on Android. – Irfan Latif Jul 12 '20 at 13:04
  • Checkout out those answers. This domain name was set up some weeks or months ago so should not be a replication issue. As I said it works fine on every other device. I have tried Wifi and 4G and got the same result. – Roaders Jul 13 '20 at 14:22
  • @Roaders what do dig and doh tell? – Irfan Latif Jul 17 '20 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.