When my old 16 Gb microSD card I used in my LGE V10 (h900) running Android 6 failed, I bought a new card; opting for a Sansdisk 64Gb microSD card. But since I inserted the card, I have not been able to write, edit or delete anything on card using my phone. I can do so readily by plugging my phone into my Win10 computer through USB, but when I try to access the card with any apps whatsoever except the built-in file manager app, and try to do any sort of write-related functions on it, they always fail.

Most commonly, I've tried to create folders on the SD card, but every time, I get the message "Folder failed to be created".

I first noticed the problem when I tried to set the SD card as the backup save location for SUPER BACKUP. Trying to select the root of the SD card, or any other folder that was added by formatting the card similarly fails, and even adding an extra folder using the built-in file manager didn't allow me to set that as the save folder for SUPER BACKUP.

So, I tried accessing it using ES FILE EXPLORER. It could read the card, but I could not move any files or folders onto it using ES, nor could I create any files or folders on it, or delete existing files or folders on it.

As per advice online, I downloaded the FX File Explorer App, and it recognized that my SD card was write only, and I used FX own auto-function to grant Write access to it, and the process seemed to run properly, and it recognizes my SD card as -RW, but whenever I try to move, create or delete anything on the SD card, I get the "folder was not created" error (or whatever I was trying to do).

I tried using FX to remove the write permission, then restarted the phone, and had it give write access to the SD card anew, and again, the process seemed to work without problems, but I still could not write to the SD Card using FX or ES.

I tried Unmounting the card, turning off the phone, extracting the card, cleaning the terminals with an erased and cleaned out the slot on my phone with canned air. Still couldn't write to the SD card.

I tried using the Storage Settings function to reformat the card. Still nothing. Again, I tried unmounting it, and reinserting it, but I still couldn't write to it.

Now, for some screwy reason, WIN10 won't assign the V10 a drive letter when I plug it in to the computer, so I couldn't use any fix that required targeting a drive or volume, so I ordered USB 3.0 SD Card reader, and plugged the card directly into the computer. There, I tried several so-called "fixes" I found online

  1. I used an elevated Command Prompt to use DISKPART to remove the WriteOnly attribute from the card (which is seemed to do), but upon plugging it into my phone, it still wouldn't let me create folders or files, move files or folders onto it or delete files or folders from it, giving me the same "failed" error.

  2. I used Diskpart to again try removing the WriteOnly attribute from it, targeting it both by first Disk number, and then by Volume number, then cleared the card, created a new partition and formatted it from DISKPART. That, as some might suspect, ran me into the problem with cards over 32Gb not being able to be formatted with FAT32 by DISKPART. I downloaded the GUI version of the Fat32Format utility, and after removing write only and clearing it card, I used it to format the card and return it to my phone. Still couldn't write to it.

  3. I used DISKPART again to try formatting it as NTFS, but my phone read that as corrupt, so I formatted it on the phone, making it exFAT, but still no access, even after using FX Write Access granting function on it again.

  4. I tried using the Write Protect removal function of EASEUS TOOLS M BETA. At first, it read it as not having any write protection, but I ran the tool, and it apparently put write protection onto it. I then used the tool again to remove the write protection. Still no write access from my phone.

  5. The card is brand new; it's from a reputable mainstream card company (Sansdisk), bought from Amazon.ca (not one of their subcontractor companies).

  6. I've tried writing to the SD card with other file managers, including "FileExplorer", ASTRO and even Sandisk Memory Zone, but I simply cannot write to it.

Every other solution I've come across requires root, and it is impossible to root a LGE V10 from AT&T. They've locked the boot loader for some stupid reason, and the only TOT file I've found to use LGUP to root it with only has Android 5 on it, and the damned phone won't let me upload a TOT file that downgrades Android from 6 to 5.

I don't live in the US, so I can't access AT&T servers to try to get an upgrade to my version of Android. Needless to say, I'm never going to buy a phone that AT&T provides ever again, but unfortunately, buying a new equivalent phone is not something I can afford, and the phone is still working great otherwise.

The only other thing that I can think of that might possibly have a remote chance of causing it was the fact that I recently changed mobile providers, requiring me to change my SIM card from a KOODO one to a PUBLIC MOBILE one, but I'm not sure how that could have messed up accessing the SD card; they're separate sockets, despite the fact that they're situated next to each other in the battery compartment.

Can anyone help with this? It's frustrating beyond all belief.

  • 1
    Phones are off-topic, but this is a pretty standard set of symptoms for a dead card. Firmware lock has been triggered, usually by a write error. The card is toast. The safety lock lets you read, but you can never make it write again. Recover data & bin it. See superuser.com/questions/1125282/… for more detail.
    – Tetsujin
    Commented Jul 13, 2020 at 16:37
  • 1
    I had a similar problem. You have to make your phone format the card for you to use it. The card can then also be read by your pc. Format the card by windows, it can be that your phone can't make heads or tails of it. This is a security feature on android with a mismatched id or something... So I would go into the partition software on windows, remove all partitions, get to your phone, and tell it to initialize the card.
    – LPChip
    Commented Jul 13, 2020 at 16:47
  • If your card is formatted with the wrong file system your phone will either have read-only access or no access. Try formatting the card in the phone.
    – svin83
    Commented Jul 13, 2020 at 17:33
  • First of all you should use the Windows PC you have and perform a test of the sd-card if it is not forged (claims to have a larger size than it actually has flash chips). A very good test program for Windows is h2testw. The download page is German, but the tool itself also has English language.
    – Robert
    Commented Jul 13, 2020 at 17:36
  • 1


You must log in to answer this question.

Browse other questions tagged .