My wife recently went to install a game on her phone (Sims Freeplay) from Google Play. She tells me the phone had enough memory for the install (~15MB free for a 13MB app), which is why she tried.

(As an aside, I'm assuming it downloads the package, then installs from that, so you need at least twice the final space to unpack the thing correctly.)

It downloaded successfully, but when the phone tried to install the app the phone unexpectedly self-rebooted.

After booting, the game wasn't installed and the phone is reporting low memory, with <1MB of phone memory free. She's using an app to check this usage (called DiskUsage), which is reporting "System Data" as using 28MB - she's sure it was much smaller when she checked the space before attempting the installation.

Assuming she's right, I'm thinking maybe the downloaded package is still sitting around somewhere consuming space. Is this possible (given it crashed mid-install)? If so how can we get rid of it?

4 Answers 4


You can delete the cache for Play store and download provider.

Settings - > Applications - > All (tab) - > app name - > Clear Cache 

The space requirements vary app by app but all of them take up more than they package size.

  • Yeah, we'd tried this and it doesn't seem to have helped, but definitely should be the first thing to try in most cases.
    – DMA57361
    May 5, 2012 at 15:02
  • In that case the apk was probably downloaded somewhere else other than an app's cache. Factory reset is the only thing I can recommend.
    – user13391
    May 5, 2012 at 15:14

Yah, the system will crash if you don't have enough disk space to download and unpack an APK. A really silly design flaw that's been around since the first Android OS version.

Anyway, the offending data is probably stuck in a cache somewhere, such as the system tmp directory.

Go through Settings > Applications and click on the All tab. Scroll down until you can click on the entry for "Play" and then click the "Clear cache" button to ditch stuff in the Google Play cache folder. Don't click "Clear data" as this will put Google Play back to the factory default settings. It will list how much space the cache is taking up above the button, btw. If that isn't much help, you can also try clicking on other apps and clearing their caches. (map, email and browser apps usually have a boatload)

You might also want to download and install a cache cleaner to wipe the other caches clean if you're running low on space; something might be a disk hog.


You can go to setting-.apps-all and then find the apps that has the "CONTACTS" word on it. I think there's two of them .

Then clear the data of those and your problem is solved.

it works for me!

  • Are you sure this won't delete any contacts stored inside the phone? AFAIK, "Contacts Storage" store the contacts info on the phone...
    – Andrew T.
    Feb 17, 2015 at 0:39

The package which the game downloads (after installing from Google Play that is) is downloaded to the SD Card.

Your best bet is to remove the app from 'Manage Applications' option under Settings.

  • The app isn't listed under Manage Applications - or anywhere else - for removal or uninstallation to be an option.
    – DMA57361
    May 5, 2012 at 12:41
  • Install OneTap Cleaner or SD Maid. Later is very good in removing hidden files. OneTap Cleaner will help too. May 5, 2012 at 12:45
  • If you only have 1MB free you can't install apps. The app is not downloaded to the sdcard. It either goes to cache or data.
    – user13391
    May 5, 2012 at 13:34
  • I know that. You can always uninstall a few apps and re install them again. I don't think that's a lengthy procedure. And I don't think I've stated that the app is downloaded to the SD Card. I've stated that the DATA that the app download (most of the times) goes to the SD Card. May 5, 2012 at 16:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .