2

I installed LineageOS on my OnePlus One (bacon) a few months ago. With Covid-19 lockdown it was weeks before I noticed that the SIM card isn't being detected. I thought it might be damaged, but EE sent me a replacement, and inserting it changed nothing.

Could it be an absent LineageOS driver? Is that likely? If so, where would I get it from? Perhaps there is a problem with the SIM connectors? As there is the "NO SIM card" message, I assume that no other diagnostic software can communicate with the SIM when it is in such a state.

1
  • 3
    If it is a general Lineage OS problem with the OnePlus One there should be more people complaining about. Check xdadev and the LineageOS bug tracker. The only way to test it would be to reset your device back to Stock ROM, if it then does not detect your SIM the SIM slot may be detect.
    – Robert
    Jul 22 '20 at 20:35
2

I think I found a solution to this. In my case, the SIM stops working every time I place the SIM into another device and back into my Oneplus One (Lineage OS). It works perfectly until I remove the SIM card, put it into another device, and then back.

I have tried factory data reset, different custom OS, stock OS, Ubuntu Touch, nothing worked. After having tried hundreds of different variations, here's the recipe:

  1. Flash Lineage OS recovery
  2. Install Lineage OS (all with SIM inserted)
  3. After install, boot into the system. SIM won't be detected at this point
  4. Go back to the recovery mode (Vol. Down + Power for several minutes)
  5. Format cache data ONLY
  6. Boot back into the OS. Sometimes the SIM will start working even at this point but if not, just do a factory data reset now (initiated from the OS settings) and the SIM will be working perfectly

I don't know if anyone else will find this useful or maybe it's just pure luck and it is indeed totally random whether it works or not, but I have done this a few times after having succeeded to test stability, and so far this method works every time.

1
  • I won't get a chance to try now for some time, but I'm happy to go for a green tick for now. Mar 29 at 21:18
1

I got it fixed by creating the APN manually

2
  • 1
    The Access Point Name? Could you explain a little more? Sep 23 at 18:23
  • 1
    Mobile network > Advanced > Access Point Names. Here I created a new one using only the information posted online by the provider (leaving everything else untouched). Comparing the newly made one with the old one, there were some differences, like the newly made one didn't specified a port or a password
    – uIM7AI9S
    Sep 25 at 6:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.