0

ghost touch selected it.

I'm on lollipop.

Edit : screenshots for comment below. I also checked Reset Default Apps in,the Settings menu, but there's only e-mail and messaging.enter image description here enter image description here enter image description hereenter image description here

0

If It Is ( Google) Drive Pdf Viewer Then :-

  1. Go To settings
  2. App And Storage (Where You Can See Installed App Which Are Downloaded Or Pre Installed )
  3. Select All Tab Where You Can See System Apps
  4. Select Drive ( Triangle Logo With Three Colors Side Green, Yellow, Blue )
  5. Scroll Down And Click On Clear Defaults ( If Not Available Directly Check Permission If Available )

enter image description here

enter image description here

| improve this answer | |
  • I don't remember what the name was, but had a red document icon, like Adobe Reader, but not. It's not in the list of applications. goovle drive says no defaults set and the button is grayed out, ghosted. I don't have enough screen for a screenshot with both name and button. I'm afraid I don't follow when you say "directly check permission if available." – Gudeez Jul 24 at 23:05
  • Can u open any random pdf file with it and then send screenshots of opened file and opened app in recent list – Kirandeep Maan Jul 25 at 4:35
  • Other is to check every apps launch by default, Normal red logo of PDF viewer is by uc browser, mega app Which i used but u have to check every app one by one its time consuming but will solve ur problem and let me Know which file manager u using they also have inbuilt PDF viewers – Kirandeep Maan Jul 25 at 4:41
  • New screenshot added. Yeah, I really don't favr trolling every application, so I'll leave that for tomorrow nite if I have to. I've got ES File Explorer and the stock file manager. I added MiXplorer recently, but had the viewer beforehand. – Gudeez Jul 26 at 0:42
  • Its logo and interface says its drive inbuilt pdf viewer if u don't have data on drive just clear data and then see. – Kirandeep Maan Jul 26 at 2:43
0

I don't use google so no data (of mine) to lose, and that did it.

I did manage to find the core problem, tho. Opening an image file did the same problem : ghost touch selected Default as I tapped Gallery. Of course, Gallery is right on the application list but again no default was set there or under Clear All... but I deleted the data and fixed it.

Something clicked that I thought to check ES File Explorer so I set Gallery as Default again and checked that app, ES. It didn't have a Default but I deleted that data and that also restored the Open With... menu!

So that's the problem : browsing with ES or maybe other file managers and selecting a default only applies to that manager (confirmed via browsing with the stock manager), and why no default shows in the application manager, and the solution is to delete data for either the defaulted application, if known, or the file manager.

Poor design on either ES or google's part or both.

Thanks, @Kirandeep Maan, for the help and getting this solved!

| improve this answer | |
  • U can give a try to solid file manager, Fx File manager or Astro file manager else if its same probably system bug for sure – Kirandeep Maan Aug 6 at 6:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.