0

I have a OnePlus 6T running Android 10 / OxygenOS 10.3.4. The problem I'm about to describe has, I believe, been present since the system upgrade to Android 10.

Screenshot showing suggestions

I started seeing these suggestions on various notifications - mainly from messaging apps; the above is a WhatsApp notification. I don't want them, and didn't have a clue how to turn them off because I didn't know what they were called.

Googling various related things ('suggestions', 'smart notifications', etc.) didn't get me any closer, but I eventually found some article on a feature that'd just debuted called 'Adaptive Notifications'. While it didn't mention the above behaviour explicitly, I figured this must've been it.

Switching them off (temporarily)

Sure enough, when I dug through my settings, found the option under Apps & notifications > Special app access > Adaptive Notifications, and switched it to 'None', these suggestions on notifications disappeared after a few minutes.

However, they periodically reappear after I apply a bunch of Play Store updates - and every time they do reappear, I find that 'Adaptive Notifications' has been re-enabled in my settings.

I'm unsure precisely what updates trigger this, but I'd hazard a guess at it being Play Services.

So, how do I stop this from happening?

3
  • @beeshyams I'm not sure I understand. Selecting 'Android Adaptive Notifications' makes the 'suggested actions' on notifications re-appear, which is exactly what I don't want. Jul 28 '20 at 14:27
  • Oh. OK. I thought on your device it appears different. Please ignore
    – beeshyams
    Jul 28 '20 at 14:28
  • I've just found out that these are called smart actions: xda-developers.com/smart-actions-set-reminders-notifications - still no idea how to get rid of them for good though Aug 8 '20 at 18:37
1

While this setting keeps turning itself back on after certain updates, I've finally figured out how to switch off these 'smart actions' (apparently that's their actual name - see my above comment).

  • As per the above, go to the Adaptive Notifications setting. Switch it on.
  • Go to Settings > Apps & Notifications > Notifications.
  • Scroll down and hit Advanced.
  • Scroll down to Suggested actions and replies. Switch it off.

I'd seen this setting before, but it was greyed out. The missing step was re-enabling adaptive notifications.

Screenshot of the above setting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.