1

I'm trying to unencrypt my data on my device.

My device is rooted with Magisk Manager.

This is what I have already tried.

  1. Uticked the box Preserve forced encryption in Magisk Manager.
  2. Patched the boot image in Magisk Manager.
  3. Flashed this patched boot image to my device.
  4. Formatted userdata thru ADB.

But after this my userdata is stilled encrypted.

Thank You, Sruly

8
  • 2
    you need to patch /vendor/etc/fstab.mt6762 see this example for userdata partition flag encryptable= and 'fastboot format:ext4 userdata' – alecxs Jul 30 '20 at 19:34
  • 1
    Looking at that example I'm not sure what the encryptable= should be. There are 2 places in that example that have such a statement. – Sruly Jul 30 '20 at 22:23
  • 1
    /dev/block/platform/bootdevice/by-name/userdata – alecxs Jul 30 '20 at 23:18
  • @alecxs I have now another device that I'm trying to unencrypt. Even after changing the fstab.mt**** file it goes back to its original form after reboot. I tried to pull the vendor image and changed the file then re-flashed the image. It still goes back to its original state. – Sruly Sep 2 '20 at 21:40
  • A/B device? Forward Error Correction? – alecxs Sep 3 '20 at 0:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.