My Huawei Honour is stuck in airplane mode. I cannot disable it as the controls are greyed out.

I tried rebooting and resetting the system cache. What else can I do?

3 Answers 3


Do you definitely have a SIM in your device? If you do not, then you cannot disable airplane mode.

Also, are the items in the Power Options menu and the Wireless and Networks settings menu disabled? If so, it is likely a SIM error.

  • 5
    You can still enable/disable airplane mode without a sim card. There are other radios besides cellular. Wifi, bluetooth and NFC for example.
    – user13391
    Commented May 6, 2012 at 16:52
  • I do. Yet I do wonder why I am not asked for my PIN now that you mention it. All I see is "no service". I assumed it's because of the airplane mode.
    – k0pernikus
    Commented May 6, 2012 at 17:56
  • Are you sure that you are in airplane mode? Could it be that you actually have no signal?
    – Liam W
    Commented May 7, 2012 at 17:35
  • 1
    In my case, it indeed was an sim issue. I reinserted it and it worked again.
    – k0pernikus
    Commented May 8, 2012 at 21:21

It looks like you'll have to do a factory reset.


I had the exact same problem in my Galaxy SII since yesterday, this post was the solution http://www.inflightmagazine.co/?p=351

The author refers to two steps to solve the problem, I would add the following steps between Step 1 and Step 2

  • Install BusyBox from the play store
  • Open BusyBox after rooting, grant it superuser permissions
  • Click install on the left bottom corner of the screen
  • You'll be asked to use Smart Install vs Normal Install.. I chose the first option, not sure if it makes any difference if you pick the second one
  • Proceed to step 2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .