I run Linux (Ubuntu 12.04), and I have a Galaxy Nexus running Android 4.0.4. (Purchased in December 2011.) When I plug the phone in to the PC via USB there is no detection whatsoever. Tailing /var/log/syslog when plugging or unplugging the phone there is ZERO activity in the logs.

The phone however will charge.

Plugging the phone into a Windows 7 machine, same deal. Phone charges off USB but Windows never prompts to say the device has been detected. Also same on MAC.

Using the same micro USB cable, and an HTC One X. Linux, Windows and Mac all detect the HTC phone AND the phone charges.

I have been to Settings -> Storage and changed the phone from PTP to MTP, still no change.

From memory this is the first time I have ever wanted to plug the phone into the PC. So it may have never worked.

Is there something I am missing (like a setting or something?) or can I assume that the phone is faulty?

  • Have you tried another cable? I've had instances where a cable works well enough to charge but not otherwise.
    – ale
    May 8, 2012 at 13:10
  • 1
    Yeah, I thought that maybe my cable was only wired for charging, so went and brought a specific data one, and still the same. Also, both cables work with other Android phones.
    – thepearson
    May 8, 2012 at 20:33
  • disableling the usb fast charging worked for me ..... Thanks! It was really kernel issue. I updated my kernel to fransisco r378 for fast charging.
    – user35289
    Jun 5, 2013 at 9:30

5 Answers 5


If you've installed the kernel mod for "fast usb charging" it will not be able to connect as long as that feature is enabled. You don't mention being rooted, but that is a side effect of the fast charging.

  • Thanks for your comment, I haven't installed this module. The phone is not seen by another version (11.10) of Ubuntu, Windows or Mac computers.Other android phones and USB storage devices work just fine.
    – thepearson
    May 8, 2012 at 21:22
  • The only other setting that can effect how you phone connects via usb would be USB debugging under Developer Settings, though you should still see some devices being enumerated on the PC side of things. Bear in mind that (at lest in my experience with a Galaxy Nexus) you need to unplug and replug after changing these settings. Barring that it may be some hardware problem.
    – Brandorf
    May 8, 2012 at 21:46

try lsusb (LSUSB lowercase) in Ubuntu, if you see your phone ID (04E8) in the list, you have to add to the /etc/udev/rules.d/53-android.rules the following line:

SUBSYSTEM=="usb", SYSFS{idVendor}=="04e8", MODE="0666"
  • Ubuntu (or windows or Mac) doesn't see the phone when plugged in. So lsusb does not show the device.
    – thepearson
    May 8, 2012 at 3:11
  • then, i'm sorry to say, your phone usb port is most probably fried. you may try other computer/port/cable/phone to make sure that's the case.
    – lenik
    May 8, 2012 at 5:19

Make sure you have USB Debugging enabled in Settings > Applications > Development.

Also you might want to try wireless adb - I use it all the time for debugging and find it so much easier than using cables. ROMs like Cyanogen support ADB over network out-of-th-box. For stock ROMs there are apps like WiFi ADB.


Is some kind of MTPFS installed on Ubuntu? If not, it won't recognize your phone's storage. You'll also need the udev rule @lenik talked about (see this tutorial). However, if as @lenik mentioned your phone isn't seen by lsusb it's most likely some kind of hardware problem with the phone itself.


It turned out it was a faulty USB port on the phone. I have since purchased a new phone and everything works as expected on the new one.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .