1

I have successfully installed lineage os on a nexus 6 that worked perfectly with stock android. That is the extent of my experience with non-stock android.

I have a google pixel (sailfish) device that a long time ago stopped working. I could boot into android, but the CPU seems to race, as it gets extremely hot, and then freezes and eventually reboots, shows a google splash screen for a few seconds, reboots again, and is stuck in a constant state of rebooting. I let it cool off, rebooted into android, quickly (I usually only have a minute or two before it overheats) enabled developer options, enabled oem unlocking, enabled usb debugging, and then rebooted into fastboot. The phone is stable in fastboot (does not get hot, does not freeze or reboot), which suggests to me that the problem I am having is not necessarily hardware.

In addition to serial numbers and memory amounts, the fastboot screen indicates the following:

Product/Variant: sailfish-US-PVT
Boot-slot: a
Console: DISABLED
Secure Boot: PRODUCTION
Device is UNLOCKED

I tried booting into twrp:

$ fastboot boot twrp-3.4.0-0-sailfish.img 
downloading 'boot.img'...
OKAY [  1.190s]
booting...
OKAY [  0.956s]
finished. total time: 2.146s
$

But the phone reboots into the google splash screen, and is stuck in the same infinite boot loop as before.

I have tried many different twrp versions, including twrp-3.2.3-1-sailfish.img which the maruos website suggests, all with the same result. I also admit that I have done various other things out of desperation, like erasing partitions and attempting fastboot format commands, most of which gave errors and did not complete. I also tried booting into recovery mode from fastboot screen, but that takes me to the same google spash/loop.

Can anyone help and provide suggestions for what to try next?

  • fastboot boot is not working on all devices. try fastboot -c "lge.kcal=0|0|0|x" boot – alecxs Jul 31 at 18:29
  • Thanks. fastboot -c "lge.kcal=0|0|0|x" boot twrp-3.2.3-1-sailfish.img takes me to the same google splash screen / boot loop – user329602 Jul 31 at 18:41
  • ask in TWRP support thread for someone sharing a working twrp boot.img you can flash straight without installer – alecxs Jul 31 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.