5

I tried installing an app on my phone from the Play Store website, but the install button is greyed out. What could be the problem?

The phone is a Samsung Epic 4G running 4.0

8
  • I assume you're talking about the website? Doesn't it say anything? Like that it's incompatible? – R R May 8 '12 at 15:08
  • No, nothing..just the install button is greyed. Thats it. – Raghav May 8 '12 at 15:12
  • Can you upload a screenshot? – R R May 8 '12 at 15:13
  • Actually one of my friends tried to do this. Will ask him to give me a screenshot.Thanks for the concern. – Raghav May 8 '12 at 15:16
  • 2
    Just tested. The install button is only greyed out if your device is incompatible. To test this from the device dropdown hover over the phone. It should say that This item is not compatible with your device. – R R May 8 '12 at 15:24
4

The install button is greyed out if you have no compatible device linked to your Google account.

Play store screenshot

3
  • I am getting this issue and my phone is compatible. It seems there is some other reasons... – Loenix Nov 19 '20 at 7:19
  • @Loenix, check if you are logged into the same account which is linked to your phone. – Aayush Nov 30 '20 at 9:01
  • @Aayush This is the same account. – Loenix Dec 1 '20 at 10:02
16

Remove the "gl=US" at the end of the URL address.

3
  • 3
    Where does OP state having used that URL parameter? Apart from that, you might have a valid point. But users unaware will just be confused. So maybe you could edit your post and explain a bit? It might even be one has to explicitly set that parameter (maybe pointing to a different area, depending what geo-location(s) the given app is locked to). // Hint for other readers: the gl parameter stands for GeoLocation. An app might be marked available only for specific regions. But I doubt that Google would be tricked that easily, it sees the IP, so a VPN might be needed instead. – Izzy Nov 30 '20 at 1:29
  • 1
    @Izzy as weird as this sounds, this is a working solution. I arrived at the play store from google search and was unable to install Signal because I had gl=US appended somehow (though why would it not be available in the US is beyond me). – krzaq Jan 13 at 2:15
  • 1
    @krzaq see? That's what I meant by "edit and explain" ;) – Izzy Jan 13 at 17:10
2

In my case the button was greyed out when I accessed the google play store by using a web search for an app and then following the link to the play store.

If I went to the play store first and then searched for the app, there was no problem.

The solution proposed by Georgi121270 (remove the "gl=US" at the end of the URL address) solved the problem. It seems that the web search found the US version of the play store, whereas when I went directly to the play store, it took me to the version for my local region.

1

In my case, it says the app is compatible with all my devices, but the reason seems to be that the app is not available in my region (this is not mentioned anywhere).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.