2

Phone Maker: TECNO Model: F1 OS: Android 8.1 (Go Edition) Memory: 8GB ROM 1GB RAM

I have asked a question here: Android fastboot restoration points

In summary the phone was updating then the battery died and now it is stuck in fastboot mode. It shows the text => FASTBOOT mode... in the bottom left corner of the fully black screen.

I discovered its possibly a single slot device (does NOT support seamless system updates) and obviously the update process got bad. What are the ways to recover from this (fastboot mode screen) so the phone boots up correctly. I am currently using ADB, Fastboot to interact with the phone via USB. Below is the output that I get when I run 'fastboot getvar all' on a windows 10 system.

(bootloader)    max-download-size: 0x8000000
(bootloader)    partition-size:flashinfo: 1000000
(bootloader)    partition-type:flashinfo: raw data
(bootloader)    partition-size:userdata: 14ff80000
(bootloader)    partition-type:userdata: f2fs
(bootloader)    partition-size:cache: 7000000
(bootloader)    partition-type:cache: ext4
(bootloader)    partition-size:system: 59000000
(bootloader)    partition-type:system: ext4
(bootloader)    partition-size:keystore: 800000
(bootloader)    partition-type:keystore: raw data
(bootloader)    partition-size:secro: 600000
(bootloader)    partition-type:secro: raw data
(bootloader)    partition-size:oemkeystore: 200000
(bootloader)    partition-type:oemkeystore: raw data
(bootloader)    partition-size:metadata: 2500000
(bootloader)    partition-type:metadata: raw data
(bootloader)    partition-size:nvdata: 2000000
(bootloader)    partition-type:nvdata: ext4
(bootloader)    partition-size:tee2: 500000
(bootloader)    partition-type:tee2: raw data
(bootloader)    partition-size:tee1: 500000
(bootloader)    partition-type:tee1: raw data
(bootloader)    partition-size:frp: 100000
(bootloader)    partition-type:frp: raw data
(bootloader)    partition-size:vendor: 12000000
(bootloader)    partition-type:vendor: ext4
(bootloader)    partition-size:expdb: a00000
(bootloader)    partition-type:expdb: raw data
(bootloader)    partition-size:odmdtbo: 1000000
(bootloader)    partition-type:odmdtbo: raw data
(bootloader)    partition-size:logo: 800000
(bootloader)    partition-type:logo: raw data
(bootloader)    partition-size:para: 80000
(bootloader)    partition-type:para: raw data
(bootloader)    partition-size:recovery: 1000000
(bootloader)    partition-type:recovery: raw data
(bootloader)    partition-size:boot: 1000000
(bootloader)    partition-type:boot: raw data
(bootloader)    partition-size:lk2: 60000
(bootloader)    partition-type:lk2: raw data
(bootloader)    partition-size:lk: 60000
(bootloader)    partition-type:lk: raw data
(bootloader)    partition-size:seccfg: 40000
(bootloader)    partition-type:seccfg: raw data
(bootloader)    partition-size:persist: 3000000
(bootloader)    partition-type:persist: ext4
(bootloader)    partition-size:protect2: a00000
(bootloader)    partition-type:protect2: ext4
(bootloader)    partition-size:protect1: a00000
(bootloader)    partition-type:protect1: ext4
(bootloader)    partition-size:nvram: 500000
(bootloader)    partition-type:nvram: raw data
(bootloader)    partition-size:proinfo: 300000
(bootloader)    partition-type:proinfo: raw data
(bootloader)    partition-size:preloader: 40000
(bootloader)    partition-type:preloader: raw data
(bootloader)    off-mode-charge: 1
(bootloader)    warranty: yes
(bootloader)    unlocked: no
(bootloader)    secure: yes
(bootloader)    kernel: lk
(bootloader)    product: K80_BSP
(bootloader)    version-preloader: 0.1.00
(bootloader)    version: 0.5
all: Done!!
Finished. Total time: 0.142s

I tried the command fastboot reboot recovery but it responds ok and still displays the fastboot mode text

How can I: 1.) Recover the data by booting into the recovery partition (right now I am unable to access the recovery partition) 2.) Recover the data and boot the device via other means apart from recovery partition

Flashing the phone is a last resort. But is it possible to Flash the phone and still retain the data I had on it before this incident occured?

PS: For obvious security reasons I only intend to stick with official tools (ADB, Fastboot) to solve this problem. I am NOT willing to install any unofficial software on my computer.

  • @alecxs I intentionally removed the actual values and replaced them with xxx. It shows actual values I am able to see it in the command line output. When I use key combos I am able to get into recovery mode. But I do not want to do a factory reset, at least NOT yet. – thinkhjj Aug 8 at 10:56
  • fastboot reboot recovery is a command I have seen in the xda forums while researching into this matter – thinkhjj Aug 8 at 10:57
  • @alecxs I have modified the question above. been doing some research and found its possible to flash the stock rom via fastboot. – thinkhjj Aug 8 at 23:58
  • fastboot is disabled (bootloader) unlocked: no therefore your only hope is SP Flash Tool. in your case most likely only system.img must be flashed, and cache partition should be cleared. in any case your personal data is on userdata + metadata partition and should be backed up with valid scatter file (just to keep it safe) – alecxs Aug 9 at 8:24
  • scatter does not fit scatter file. you must create scatter file for your own. Do a "read back" of your phone. in SP Flash Tool select DA_SWSEC.bin as Download-Agent (source). you can follow below instructions afterwards – alecxs Aug 9 at 9:02
2

You may be able to restore your phone using SP Flash Tool since you phone uses MediaTek CPU

1- Download SP Flash Tool

2- Download the ROM from here

3- Download the driver from here installation steps inside the zip "README" file

4- power off you phone

5- open SP Flash Tool. Go to Download tab Click Scatter and Load Scatter File from ROM Folder

imageedit-0-6226621777.png

6-Select Download Only. Click Download & Connect the Switched off Phone

imageedit-0-5557492297.png

| improve this answer | |
  • Thx for that answer. You could improve that with a warning one should always uncheck preloader android.stackexchange.com/q/227124 – alecxs Aug 8 at 12:14
  • Thanks for the response. I hear fastboot can flash ROM also. Stumbled on instructions here forum.xda-developers.com/android/help/… I am comfortable with the command line so running commands isn't scary to me. Any input on how to achieve this with fastboot via CLI? – thinkhjj Aug 8 at 22:47
  • be aware fastboot flashing unlock will perform a factory reset which causes data loss – alecxs Aug 9 at 8:40
  • Thanks a lot for all of the feedback. I have obtained SPFlashTool using the link from @theggputest55. Questions: 1)How do I create a scatter file for my device?(is it possible with SPFlashTool or can it be done via command line?)Now I know scatter file is basically a .txt file how do I get it from my device with SPFlashTool? 2)When I have the scatter file how do I use it to make a backup of my partitions? 3)Now when I want to flash the ROM, it is this same scatter file that I will use in SPFlashTool yes? – thinkhjj Oct 23 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.