0

Error number 1:

Emulator: E0809 05:21:56.677723102 2704 socket_utils_common_posix.cc:201] check for SO_REUSEPORT: {"created":"@1596930716.677712232","description":"SO_REUSEPORT unavailable on compiling system","file":"/mnt/tmpfs/src/android/emu-master-dev/external/grpc/src/core/lib/iomgr/socket_utils_common_posix.cc","file_line":169}

Error number 2:

Emulator: KVM: injection failed, MSI lost (Operation not permitted)

The AVD works fine otherwise with no issues, I was just worried why I was getting these errors. I was not compiling an app or anything while running the AVD. The first error appeared when I started the AVD and the second error appeared upon shutting it down.

I get two other messages that don't seem to be errors but I am including them anyway (both of these below appear upon closing the AVD. Only the first error appears when the AVD is started):

Emulator: Process finished with exit code 0
Emulator: deleteSnapshot: for default_boot

The AVD is running Android Q (API level 29) x86_64 image with Google APIs and the device I am virtualizing is Pixel 3

Here are my PC specs: 16 gigs of RAM

  • 16 Gbs of RAM
  • Intel i3-8100 CPU
  • Linux Kubuntu
  • 120 gig SSD (that Linux installed on)
  • 1TB HDD and another 240 GB ssd for Windows (unncessary info I think but I included it anyway)
2
  • Error in the emulator log are nothing unusual. If everything works you can ignore them. – Robert Aug 9 '20 at 10:33
  • @Robert you sure? – Sbeve Sbren Aug 11 '20 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.