The Error:

when running the ubuntu install script (ubuntu.sh) I get:

ubuntu.sh[11]:cut not found
This script requires root! Type:su

what I have done so far:

Installed a custom kernel that roots the phone:



I installed it using Odin using the following instructions:


that all seemed to go fine.

Installed "Ubuntu Installer Free" from market place.

I then installed busybox:

tried Stephen (Stericson) and JRummy16 apps from market place.

I installed the VNC viewer as recommended by Ubuntu installer app.

I also installed Android Terminal Emulator (Jack Palevich) as recomended by Ubuntu installer app.

Downloaded and de-compressed the image and script as per links from Ubuntu installer app.

I decompressed them to my external card initially but then moved them to the "internal" sdcard folder.

I also tried to establish that I had loopback device capability.. I found this thread:


And the folders mentioned are present.

I think that is all i have done so far ;-)..

I had a look at the script and the failing line and it seems to me if the "cut" command was not found then it would report that i didnt have su privelages even if i did.

I have many times ofer forgotten and approved su access for terminal emulator and busybox..

When I type su in the terminal emulator the symbol for text entry changes from $ to# ..

Anyone got any ideas?


Try running su from the terminal first, then run ubuntu.sh again.

| improve this answer | |

Open the script up using an app, such as root explorer, and add the line su to the beginning, and try again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy