I am new to this forum and would really want to please help me get this problem solved. I just bought a Sony Ericsson Xperia X10 and tried connecting it to my internet at home (Belkin N1 router - 64-bit WEP encryption) but it does not connect at all. It catches the internet connection and says its in very good range, I put the key but it never connects. I have tried all the different things possible via this forum, googling for answers, etc but haven't found a solution yet.

Stuff that I have tried:

  1. Tried accessing it via a static i/p technique.
  2. I cannot change the WEP encryption to WPA-PSK because the internet is set up by my landlord and I am not allowed to change it. I can check the settings and it shows access to all b/g/n configurations.
  3. I have another phone i.e. the new Sony Xperia S, even that is not able to connect to my wifi.
  4. I am able to connect both these phones very easily to other wifi's having WPA-PSK connectivity but just not my home network.


I have been able to partially solve the problem but it is not the exact solution that I am looking for. Here's what I have tried:

I have tried the WPA-PSK approach (AES encryption) and it does somehow make it work on my Xperia S (it did not connect to it instantly). Basically, there is an option of WPS (Wifi-Protection Setup) in my Xperia S which allowed me to do a Push Button Configuration (PBC) i.e. holding the router button for 3 seconds to allow my phone to access it. It assigned me an i/p address and thus made it work but spoiled it for my other housemates, so I had to get the setting back to WEP.I know it is more secure to use WPA, but I cannot change it without asking my landlord. Anyways, the point is that somehow my other phone connects to the router not instantly but via some route as given above. My question again is: Is it really not possible to connect it via WEP?

Kindly help as I have been struggling a lot to find for a proper solution over the internet.

  • Do you mind telling the length of you WEP key?
    – roxan
    May 9, 2012 at 15:36
  • 8 digits is the length of my WEP key = 03C004E1 (something like that). Dont exactly remember now.
    – Neophile
    May 9, 2012 at 15:50
  • Currently wireless channels are 6 and extension channel is set to 10.
    – Neophile
    May 9, 2012 at 16:40
  • 1
    Original key is: 0e39c004e1
    – Neophile
    May 9, 2012 at 16:43
  • 1
    You should definitely avoid WEP because the algorithm is broken. Your network can be cracked, in the worst case, in a couple of hours and in the best case in minutes. Your landlord cannot force you to keep an insecure network in your house as well as he cannot force you to keep a broken door lock for it. Remember that if someone breaks into your network and does something nasty, you are in charge of proving that you are out of it.
    – Avio
    May 16, 2012 at 9:11

3 Answers 3


64-bit WEP key in ASCII mode is 5 characters, and since you've said your WEP key is 0e39c004e1, you have to enter it in HEX mode. I'm not sure if your phone can handle HEX input, so if I were you, I'd try to (temporarily) assign some other WEP password, which can be entered in ASCII mode (5 random characters, letters or numbers), and see if that works from your phone.

Since you've mentioned that both your phones, Xperia X10 and Xperia S have the same problem with this router, it might be a good idea to invest about $30 in small WiFi router, which can connect to your home network and serve internet to your phones and other wireless devices. I use TL-MR3020 and it works perfectly in many situations.

  • Nope, I tried it and it doesn't work unfortunately.
    – Neophile
    May 13, 2012 at 21:45
  • you have mentioned "Xperia S" in you question, is this a different phone? if you have access to the different phones and different routers, it might be a good idea to check and see which phone can connect to which router. this might help to isolate the problem, be it with your phone or with your router. from my other experience, Sony devices can be quite picky about connecting to some type of routers, while everybody else does not seem to have any problems. had to change my router once because of this.
    – lenik
    May 14, 2012 at 8:31
  • I have added an Update section just below my question telling what I have tried with the Xperia S and how I was able to kind of solve the problem but I am sure it is not a phone problem and more of a wifi issue. Both these phones work absolutely fine on any other WPA-PSK router. I have tried both of them at work and other places. No problems as such. Its only the WEP connection that has created these problems.
    – Neophile
    May 14, 2012 at 8:43
  • do I understand correctly that both your phones, Xperia X10 and Xperia S have the same problem with this router?
    – lenik
    May 14, 2012 at 15:05
  • Yes. That is correct.
    – Neophile
    May 15, 2012 at 9:15

I think this is most likely a problem with the Android platform itself. My own LG P500 phone won't connect to any WEP secured network even though the key is 100% correct. In that case it was an iMac desktop with connection sharing through WEP, as that was the only option available for sharing.

It's not ideal, but perhaps finding a good compelling article about the benefits of WPA over WEP and presenting it to your landlord might be the easiest fix here.


I just thought of posting my solution here as well in order to help others that might face this problem in the future. After troubleshooting the problem for over two months, I have finally been able to resolve the problem with the help of a Belkin technical support engineer. Just for clarification, the problem is neither with the phones nor the router. It is to do with the Wifi settings that can be accessed via the gateway i/p address (In my case it was: I have followed the below steps that made it work for me (Please note that this solution may not help all the other WEP problems, it just seemed to help in my case. The best idea is to check up with your router's technical support department unless there is a problem with your phone).

Wifi settings changed:

  • Disabled Firewall
  • Disabled WAN Ping Blocking
  • The most important part:
  • Under Security, I changed the Wireless channel from '10' to '9'.
  • Changed the Configuration from "802.11 b/g/n" to "802.11 g only".
  • Changed the SSID name from say: "Belkin-Router" to "Belkin".
  • Applied changes and hurray, my phones got instantly connected.

Hope this helps others as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .