0

I usually use my Android device (Samsung Galaxy S7, Android version 8.0.0) to debug my app from my Mac (developer option enabled). Usually when I connected my Android, the Android File Transfer will start to jump around to complaint that it can't browse my Android, and on my Android, it will ask some kind of permission for the computer to access local files. After I say yes, the Android File Transfer will immediately show my Android file contents. But even without that, my Android will usually still showing up on adb devices.

But today, nothing showed up on my Mac, at all. Android Studio doesn't see anything. adb devices doesn't show any device connected. The Android also doesn't show any sign that it's connected, like a kind of notification that it's connecting using MTP or PTP. Now there's no such notification. The Android File Transfer also silent. If I open it manually, it shows "No Android device found. Please connect your Android device with USB cable to get started." But the Android device is still charging.

I tried using different Android device, using the same cable. The Android File Transfer happily jumped around at the first chance. So it's not about the cable either.

How can I fix this?

3
  • Check the Android USB settings if it is set to "Charge only".
    – Robert
    Aug 24 '20 at 11:46
  • @Robert it’s set to MTP. I do see an option above it says “charge only”, but the currently selected option is “MTP”. Aug 24 '20 at 13:01
  • And sorry to state the obvious, you have rebooted both devices (phone and Mac)? I've had to do that sometimes on my Mac. Aug 24 '20 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.