I have a T-Mobile G1 (HTC Dream), this morning it vibrated once and then restarted, it then went to the android boot logo went through that and stopped at a black screen.

I've tried pulling the battery and restarting but it has the same problem.

The phone is rooted but it has NO custom boot screen, boot loader, rom. It has stock everything apart from the ability to use root.

Running Android 1.6

Anyone any suggestions, I intend to take it back to T-Mobile tomorrow night when they have late opening hours, but I'd like to get it working before then.

  • On mine you can press Call, Menu, and End at the same time to make it reboot, and then hold down Home as it starts, to get to the recovery mode. I don't know if either of those are present without a custom ROM, though.
    – endolith
    Oct 20 '10 at 21:11

Have you tried doing a factory reset (you'll lose all data)?

Steps to do a factory reset are found here.

1. Power off the G1
2. Hold Home Key + End key for 20 
seconds or until you see a "triangle with an exclamation point
and a picture of the G1"
3. Open the QWERTY keyboard and hit Alt+W
4. Restored!
  • Thanks!! worked like a charm. It appears to be ok now just need to reset everything up again.
    – digital
    Oct 20 '10 at 13:32
  • @digital great! :)
    – Bryan Denny
    Oct 20 '10 at 13:33
  • I'm having this same problem, but I'm running CM6. When I boot I don't even get the T-Mobile screen, I just get a blank one. I've tried home+end, call+menu+end, etc. with no luck. Right now I can't boot into anything. Should I ask this as a separate question?
    – Mingo
    Mar 31 '11 at 1:04
  • I found this blog post, but his solution is based on actually seeing the T-Mobile screen. I don't even get that: the-dro.com/technology/g1-stuck-on-t-mobile-bootup-screen
    – Mingo
    Mar 31 '11 at 1:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.